0
Under review

Toolbox takes a long time to load if you run tool on multiple connections

mhighsmith 4 years ago updated by Ben Burner 4 years ago 8

if you run a tool on 50+ connections it will take several minutes if you connect to a system for the toolbox to load. It can even be a simple renaming of a file and this behavior happens. using version 6.1, This issue was not happening on 6.0.

Available in Version:
Waiting for information

Good afternoon,


To facilitate troubleshooting, can you confirm that these reproduction steps are correct:

1) From the host page, select 50 connected sessions

2) From the host page, right click, select Run Tool, and select a tool to run on all 50 connected sessions

3) Immediately join a session as host and click the client toolbox menu icon to start loading the toolbox

4) The toolbox takes upwards of 2 - 3 minutes to load content


Also, if you do steps 1 and 2 above, and then immediately send a simple command (e.g. 'dir') to one of the sessions from the host page, does the guest take upwards of 2 - 3 minutes to send a response to the commands tab?


Cheers,

Ben

Just verified that the commands tab dir statement is instant. the Toolbox takes a couple of min to load though. Ran a tool to delete a flag file on 75 clients. took 2 min for toolbox to be available.

Thank you for providing that additional information. Would you mind sharing how many items are currently in your server's toolbox (roughly)?


If you'd prefer to schedule a session to your environment so we investigate the root cause of the delay in loading the toolbox, please submit a request to extension@connectwise.com, and reference this thread.


Regards,

Ben

We have around 200 tools and growing.

To test this, I added 500 dummy files to the server toolbox, selected 30 access sessions, and ran a simple "tool" on each. I immediately joined a session, and the toolbox loaded within 10 - 15 seconds.


Fundamentally, the delay in loading the server toolbox items in the client is a function of the following factors: the number of toolbox items that need to be loaded, the number of queued toolbox items that have yet to be processed, and the speed at which the server can processes said queued toolbox items.


If you'd like, I'd be happy to arrange a session to your ScreenConnect server in order to attach our command line debugger to the server process and investigate the server's resource consumption as it's loading toolbox items and processing queued tools simultaneously.


Regards,

Ben

Ben,


that will be fine. here are the some of the specs of our server:


Processor(s):

Intel(R) Xeon(R) CPU E5620 @ 2.40GHz (8 virtual)Available Memory:

9942 MB / 12287 MB

Your server looks to be adequately provisioned, resource-wise.


If you'd like to schedule a session to your environment so we investigate the delay in loading the toolbox, please submit a request with your availability to extension@connectwise.com, and reference this thread.


Cheers,

Ben

Under review

Good morning,


Based on our troubleshooting session from Friday and some additional testing I conducted in our development environment, I believe this thread is more appropriately characterized as a feature request to reduce the in-client toolbox load time in situations where tools are queued on 50+ sessions from the host page immediately before joining a session.


Please feel free to update this thread with additional information to fill out the request.


Cheers,

Ben