0
Under Review

Do not allow OperationNotSupportedMessage to replicate non-stop

Simon (Annet) 6 months ago updated by Caitlin M Barnes (Product Manager) 4 weeks ago 2

We currently have DefaultAccessSessionInfoAttributes enabled for MonitorBlanked, InputBlocked, and WakeLockAcquired.

Now, our employees don't have to go through the hassle of manually enabling those features every time they access their computers at the office. Given the coronavirus, more and more of our employees are using ConnectWise Control to work remotely, and this setting made their user experience so much better.

This was all going perfect until we introduced macOS devices into the mix.

Since the Block Guest Input feature isn't supported on macOS, every time someone accesses a macOS device, it throws up an OperationNotSupportedMessage.

But that's not all — until you manually disable the feature on the host client, the message window will replicate like crazy. See the screenshot below.

The reason why the window's edges are so dark is because under that window are tens of windows just like it, as you can see in the following screenshot.

So, after manually disabling the feature, you have to click the OK button on all those windows to clean up the desktop.

We request that the message window appear only once and no more.

Additionally, it would be ideal if clicking OK on the window automatically results in the unsupported feature being disabled on the host client.

And it would be even more ideal if this feature were supported for macOS. I've heard Splashtop can block guest input on macOS devices, so it's not impossible.

Available in Version:

Hi Simon, 

Is this still happening? I tested on my Mac just now and only received a single error box for input_blocked.