+3
Under review

Support for High DPI Monitors

Brenton Nicol 2 years ago updated by kevpennymtx 2 years ago 4

Support for High DPI monitors when using multi display and having scale of the UI (for example SurfaceBook from main display to 1080 display causes UI to become oversized)

Available in Version:

This really needs to be worked on - my office setup is a Surface Pro with two 1080p external monitors.  I launch Control and it defaults to the Surface Pro high DPI screen, then when dragging to one of the external monitors all of the buttons are massive and take up far too much screen space.  Myself and the OP can't be the only two feeling this pain, and it will only become more prevalent as high DPI monitors start to become the norm.

Note that if you have Windows 10 v1803 installed then there's a way of getting this working properly using the new app-specific compatibility settings for high DPI monitors.  If you right-click C:\Program Files (x86)\ScreenConnect Client\ScreenConnect.WindowsClient.exe, click Properties and change to the Compatibility tab, then click 'Change high DPI settings', tick the box for 'Override high DPI scaling behaviour' and change the dropdown to System or System (Enhanced), then restart any Control sessions, you should find that the UI sizes itself properly on both high DPI and low DPI screens.  

+1

That did fix the issue but due to the Automate Control it was in a different location but it ticked the box,


The client for me was in AppData (had to find the location using Task Manager when a session from Automate was running) 



+1

Sorry, yes, I realised after my original comment that that applies to Control sessions from the new Automate Web Control Center (i.e. https//yourhost.hostedrmm.com/automate) but not to the local Automate client.  On my machine there are a bunch of ScreenConnect.WindowsClient.exe instances in various places in AppData, so rather than use trial and error the easiest way to find it is to right-click it it Task Manager and click Properties from there.