+13
Under review

Portal not responding

frufru 10 months ago updated 1 month ago 35

Today I tried to install the latest version and the problem is still there. I start the service and everything works fine. After an hour I can’t connect to the portal, sometimes half of the page loads but can’t see any clients. While this happens I see high cpu usage from multiple mono instances in top. If I restart the service it works again for an hour. Now back to 19.4 for the hundredth time..

-1

Thanks for letting us know, we have received several reports and are investigating.

Can you post the last 100 lines or so from /var/log/screenconnect ?

Also, what Linux OS is on the server?

Hi,

Here is the relevant part of the log. The first entry is the service stop before the upgrade. The system stopped responding after about an hour but no sign of the problem here.

Event (2020/12/08 10:46:06.900 +01:00, ScreenConnect Web Server, Information): Stopping service...

Event (2020/12/08 10:46:07.038 +01:00, ScreenConnect Web Server, Information): Stopped service.

Event (2020/12/08 10:46:07.039 +01:00, ScreenConnect Relay, Information): Stopping service...

Sending SIGKILL.

Event (2020/12/08 10:56:19.264 +01:00, ScreenConnect Session Manager, Information): Starting service...

Event (2020/12/08 10:56:20.264 +01:00, ScreenConnect Session Manager, Information): Successfully started service.

Event (2020/12/08 10:56:20.264 +01:00, ScreenConnect Relay, Information): Starting service...

Event (2020/12/08 10:56:20.862 +01:00, ScreenConnect Relay, Information): Successfully started service.

Event (2020/12/08 10:56:20.862 +01:00, ScreenConnect Web Server, Information): Starting service...

Event (2020/12/08 10:56:51.700 +01:00, ScreenConnect Web Server, Information): Successfully started service.


Interestingly today I left the server without a service restart after it hang and after some time it has recovered and at this moment I can access it again but I don’t know for how long.

One more thing I experienced, the upgrade from 19.4 fails with the following error, I need an intermediate step:


The assembly mscorlib.dll was not found or could not be loaded.

It should have been installed in the `/root/monoInstall/lib/mono/4.5/mscorlib.dll' directory.

License is not eligible to be upgraded to this version

Hello. I had the same issue with the mscorlib.dll was not found....yada, yada, yada...License is not eligible to be upgraded to this version.

This did not make sense because my license worked with a new install to the latest version 20.2, so I guessed that the problem was with the upgrade/installer.


The solution was to upgrade to 19.6 and then 20.2.

+3

Can anyone from technical support confirm that this could be a possible solution to the problem? Before we all downgrade our systems I would like to have a confirmation. Dear Connect Wise people, surely your testing department can verify this? Or would it be possible only to update this mscorelib.dll? 


Please do not keep us in the dark any longer. Almost everyone has built some kind of emergency solution with restarts and similar scenarios. It can't be that we are left in the lurch here by Connect Wise. We are now making plans to switch to another platform and if there is no viable solution by the end of the month, we will demand a refund and terminate our relationship with Connect Wise. To the rest of the community here on the forum, I'm happy to take suggestions for alternative systems. Conntect Wise is no longer one of my favorite solutions!


it hang again, after a couple of hours, here is a top screenshot:

there is nothing in the log

It does this even when the VM is isolated and no clients are trying to connect to it.  This is running under KVM/QEMU

Yeah I was having this problem so I setup a fresh VM on another computer and it is also having the problem.  The VM is running Ubuntu 20.10

It is worth mentioning that I did adjust for the libc bug you are having when I set this up by symlinking to the files your app needs but is not finding.

(If you gave us a working docker image that is a much more controlled environment and would be much easier for you to manage, debug, and release updates for)

We had the same problem since 20.1.29489.7513 under debian 9 stretch

I can't say if this fixed the problem permanently, but currently (Since the latest Debian updates yesterday) it seems to be gone.

With the updated packages, I can't really see a connection to screenconnect now either.
But maybe your technicians see a connection here ?
Here are the packages that I updated yesterday:


Start-Date: 2020-12-10 15:49:12

Commandline: apt upgrade

Upgrade: libapt-inst2.0:amd64 (1.4.10, 1.4.11), libldap-2.4-2:amd64 (2.4.44+dfsg-5+deb9u5, 2.4.44+dfsg-5+deb9u6), apt:amd64 (1.4.10, 1.4.11), libsqlite3-0:amd64 (3.16.2-5+deb9u2, 3.16.2-5+deb9u3), python-apt-common:amd64 (1.4.1, 1.4.2), libapt-pkg5.0:amd64 (1.4.10, 1.4.11), libldap-common:amd64 (2.4.44+dfsg-5+deb9u5, 2.4.44+dfsg-5+deb9u6), python-apt:amd64 (1.4.1, 1.4.2), apt-utils:amd64 (1.4.10, 1.4.11), apt-transport-https:amd64 (1.4.10, 1.4.11), python3-apt:amd64 (1.4.1, 1.4.2)

End-Date: 2020-12-10 15:49:16

I can safely confirm that the service has been running continuously without any downtime because since the problems with 20.1 we have been monitoring it with our own monitoring solution ServerSentinel every 10 minutes and as soon as the service was frozen we restarted it via a remote script action so that our developers can use the system when they have a support case.

Unfortunately a day later the problem occurred again.
Possibly this post can be deleted because misleading. It would have been too nice if this problem would have solved itself so easily after three quarters of a year.

+2

I do not understand why this is taking them so long to fix.  I have had to setup a windows computer in my house to compensate for this.  It is a HUGE pain.  They call us "partners" but I really do not feel like one.  Do they have like one programmer working on this linux problem???  I think they changed hands at some point.  After that things started going down hill.  It is a shame too because this software was (sort of is) great.  But the things that made it great are being neglected and fading away.

+1

I ran updates on my Ubuntu VM and this is still a problem. 

+2

What is the update on the resolution for this? Would like to see this resolved before the New Year!

They closed my ticket and asked me to check here for updates. Nothing but crickets.

we should get the hint

You mean they? As far as I'm concerned, they have breached their contract by not fulfilling their duties and obligations. Who is the head of this service corporation anyways?

+2

That is what they did to me too!!!!   

I do not understand why this is taking them so long to fix. I have had to setup a windows computer in my house to compensate for this. It is a HUGE pain. They call us "partners" but I really do not feel like one. Do they have like one programmer working on this linux problem??? I think they changed hands at some point. After that things started going down hill. It is a shame too because this software was (sort of is) great. But the things that made it great are being neglected and fading away.

Can we get an ETA on this issue????

ConnectWise?? Are you actually monitoring this?  Can we get a comment??

+1

So frustrated. I've kept upgrading hoping it will get better, but if anything 20.2 is worse. Restarting the service takes way longer and it stays up for even less time than 20.1. Really wish I could go back to the versions that worked. 

Happy New Year! Where are we at with this?

+1

The “Initial” bug report about this problem has been created almost a year ago (https://control.product.connectwise.com/en/communities/6/topics/2798-portal-not-responding).


Back in December ConnectWise released a security bulletin concerning a vulnerability (https://www.connectwise.com/Company/Trust/Security%20Bulletins#4ae056a7-e060-4b6f-93fd-cd4f3a2f8310) Since the fix is in version 20.13 and the Linux version is way way behind, it seems we are stuck with a vulnerable version!


@caitlin, I think we have been very patient. Like you asked, bug reports have been filled but it seems the resolution of the problem is going at a crawling speed! As a Product Manager for ConnectWise, you shouldn’t let us in the dark by giving us the silent treatment! Please be more pro-active and keep us informed about the progress (if any) and be honest with us!

+1

We've had to set up a cron job to restart the stupid service every hour.. that's the only way the server remains usable.. otherwise it gets slower and slower until finally stops listening to TCP requests for https and dies. I am annoyed as all hell because I was working just fine on an older version for a long time, then macOS clients started acting wiggy with the new macOS release, so I paid to update my license and upgrade to the latest version, and this is what I get..

I feel your pain! I have even gone as far as to re-setup our server on Windows, however we were faced with a dismal performance drop to our other line-of-business applications and went back to Linux. We've been surviving but it's extremely frustrating living in a state of limbo (two if you count COVID) for nearly a year.

+1

I think connectwise removed the linux reports from the main bug portal so this small bunch of annoying people won’t show up all the time and just be in the way with this stupid “portal is not responding” stuff. It looks like no one reads these messages but at least we can talk to each other…:)

I’m lucky because I still have a working 19.4 instance I can go back to, but sometimes I think about the major security issue if my version has is or not.

+2

If you all want them to pay attention to this.  Regularly start new trouble tickets and call sales and demand they give you a further discount on renewing your licenses since they are not following through on their commitment to supply updates.  I plan on demanding they reduce my 20% to 10% for this last year when my renewal comes up.

Echo... echo... echo.... echo.... echo... echo...

Is there anyone from ConnectWise listening here?

I doubt there is which is why you need to keep calling and demand a discount.

I just tried to submit a support ticket (https://www.connectwise.com/services/support) about the security bulletin "ConnectWise Control Host Header Injection". where I wanted to know when a secure version will be available for us, their Linux customers but I get a "403 Forbidden" when clicking the Submit button! What's the best way to contact them beside phone?

+1

Looks like no activity for a few months. Is this still a problem? I want to go back to Linux as soon as possible. Running a Windows server just for SC is expensive.

+1

Still a massive problem. Kicked us out 3 times already today and wasted no less then 35 minutes of our time :( Some days are worse than others.

+2

They emailed me reminding me to renew my membership this month.  I replied back and asked them what the point of paying for upgrades were when I am not getting them.  No response back.  I will be going at them over this again very soon.

+4

Same with me, they ask me to renew my license. I told them, I will extend, when a working linux release is available. 

Then I've got no answer anymore. 

+1

So, TWO months ago, I sent out an email to all the Execs and CEO's of ConnectWise over this and not being able to use the product I was paying them for as well as some other things.   The very next day I was contacted by an Exec who basically addressed all my concerns.  Now, I am very sorry to say that they do not *seem* to care about you people at all.  As I told them MULTIPLE times, in writing and verbally, to go onto this thread and tell you all what they told me....


They have discontinued supporting Linux.


This issue will never be resolved.  There was no official notification sent out, to me at least.  And they seem to be keeping it as quiet as possible.  So feel free to call them and let them know how you feel about this.

I did tell them that if they could get this working in a docker container then the linux issues would be much easier to resolve because it is a controlled, singular, environment.  

Sorry guys!

Also sorry that they did not have the guts to face you directly on this and felt it was smarter to leave you in the dark.  Of course if they went through this thread and called each of you directly to discuss it with you.. then I apologize.. although somehow I do not think that is in their scope of "customer service" either.

Remember when the selling point of this app was that it was a tech tool made by techs for techs...  good times... good times...

-> Merlin at Desktop Masters

+1

Merlin,

I hear you, but you are approaching this as if Connectwise cares. They don't. They actually did send out an email about it. But it's clearly time to move on. We are running Mesh Central by Intel. It's free and works much better than Connectwise Control does.

how did you manage the switch to meshcentral? i'm running sc on a vps /debian 9.13 + plesk 18/ it's accesseble via a subdomain using an nginx reverse proxy. i've gone through the documentations but i couldn’t find instructions for a similar setup so it's unclear to me how i should intall meshcentral on this vps. i never used node.js before

HUH!? Where is your source for this? OMG!!!

This link was EMailed to me by Will Reilly (very nice, and helpful guy) in response to my angry letter I sent to the CEO's at ConnectWise.  

https://docs.connectwise.com/ConnectWise_Control_Documentation/Technical_support_bulletins/End_of_Life_Notice%3A_Linux_Host_Server_for_ConnectWise_Control

My suggestion, to all of you, is to contact ConnectWise and request (demand?) they continue Linux support in the form of a docker container.  This way it is a controlled environment that they can easily keep stable... once/if they can get it working with mono again.  https://hub.docker.com/_/mono

according to the doc they offer a $99 per concurrent technician cloud option for the linux users. i don't which licence this might be, the single has a 10 agent restriction: https://control.connectwise.com/pricing/support