No mouse on Android

Zanthexter 5 years ago updated by anonymous 3 years ago 32

Just upgraded to a Pixel XL.

No mouse. App is basically unusable from my phone.

I'll lug a tablet around for now, but I hope this is fixed soon.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:



Good morning and thank you for reporting this issue with the Android app on the Pixel XL. We've had other reports of this behavior, and have implemented a fix that should be included in the next release of the Android app. While I'm unable to offer an ETA for the Android update, please refer to the ScreenConnect Output Stream for the latest development news, including bug fixes and product enhancements.




Good morning and thank you for reporting this issue with the Android app on the Pixel XL. We've had other reports of this behavior, and have implemented a fix that should be included in the next release of the Android app. While I'm unable to offer an ETA for the Android update, please refer to the ScreenConnect Output Stream for the latest development news, including bug fixes and product enhancements.



Issue is Back on Samsung Note 8, it got fixed on Pixel XL.


Do to an unfortunate mishap (suicidal phone vibrated itself off the desk) I also upgraded to a Google Pixel and have noticed there is no mouse as well with both the stable release and the beta release. Eagerly awaiting the next mobile UI to fix this gaping hole.

For anyone else looking at this thread, there is a work around. It's slow and clunky but works. Hold your finger on the point you wish to click and it will prompt a menu of what type of click you want to perform. Seems to work as long as your finger was held in the correct spot.

Seriously this issue needs to be fixed asap it's been around for over 2 months now. Its embaressing that it takes this long to fix, its clearly an issue introduced with Android 7.0 I had to remote into a PC using Teamviewer and from that PC launch screen connect from my Android phone, this issue has been around for too long now, I was expecting a fix sooner then that especially since its so crippling.


I would like to bump this, I paid a good amount of money for the cloud service and it is useless on my phone right now. I have seen reports of this bug for over 2 months with no fix or even status updates. Prime example of poor customer service.

It is still not fixed on Android 6.0.1. I still don't see the mouse on the session


Ok, I'm now rating this as "Bad, I'm unsatisfied."

First, I shouldn't have to monitor a damn "Output Stream".

Second, this is a HUGE GODDAMN PROBLEM. I am completely unable to do any remote support using ScreenConnect when not at my desk. Which is about half to all of a busy day. Why the hell is this still not fixed? I could understand a week, maaaaaybe two, but when the product becomes COMPLETELY UNUSABLE, this isn't a low priority thing.

When the hell are you planning on fixing it?

I get that I've ALREADY paid a couple thousand for the software, that you have my money so don't feel you "need" to make an effort to sell anything to me. But if you want me to pay any more money for upgrades, this needs to be addressed ASAP.

In the meantime, I'm having to pay to use Splashtop, which for all it's faults, works reliably and sure is hell a lot cheaper. In fact it handles video and graphics so much better, I'll probably leave it on the NVR systems I support. It remains usable where ScreenConnect doesn't.

Well its obvious they don't care, go complain on the forums. This is marked Fixed even though its not.

You would think they could ASK people if it was fixed.


Same issue with a OnePlus 3.

Problem reported on 26th October 2016 and it was already "known" by the devs at that time.

No news since then.


Yeah, at this point I'm basically SOL. I can't support customers remotely, and I'm remote a lot of the time. I'm stuck lugging around a laptop. Really has me angry.

I don't know that anyone ConnectWise cares, but if I was asked my thoughts on buying a ConnectWise product, I'd recommend against it. They just don't seem like a company I'd trust my business to. Not when they see this as a non-issue to be fixed "someday" along with a bunch of other stuff in a "big release".

Someday isn't good enough, sorry. Next time I get a call from a ConnectWise salesperson, I plan to give them an earful.

Shouldn't this be marked as fixed? Has been working for me on my Pixel since 6.0.12313.6240 was released back on Feb 7th...

I just purchased a Galaxy S8 and am having the same issue. Created a ticket with support but just wainting. For the time being they asked me to use the legacy app. It seems to work fine just lacking some features.


I want to apologize as I know this has been a long-standing issue and it affects many of you. This issue is no doubt a top priority, and I can ensure you all that our developers are working on a fix. Although the fix will not appear in the upcoming update this week, the fix will follow sooner rather than later. It is a bit difficult to find and reproduce some issues, such as this one before it is reported as we have few testing devices. To improve the amount of time it takes to find and fix an issue with the Control app, we will be putting together a beta test group. I encourage all who want to participate to respond to this thread or email me directly at kmartinez@connectwise.com.

I've been forced to change the OS of my OnePlus3, in order to get your app working.
I won't partecipate to the beta test group.

App is unusable I have no mouse on the Connectwise Control app. Asus Zenpad z8 android 6.0.1


Thank you for reporting the issue. I'll make sure it is registered. 


We have released fixes for S8 and PixelXL devices. We have registered reports for no mouse on other devices running 6.0.1, such as OnePlus and Moto G4 that we're investigating. I'll post updates here as they come in. 

Add one more device with this problem:

Xiaomi Mi Max

android 7.0 NRD90M


Good morning,

Can you confirm you're using the latest ConnectWise Control App for Android, version 6.2.13372?



Upgraded from Pixel XL to Note 8, same exact problem that used to exist on the Pixel now happens on Samsung Note 8. Hopefully we don't have to wait 4 months this time...

Still an issue on Samsung Note 8 guys... 2 months now.

I switched over to the Pixel 2 XL. No issue on here atleast!


I got sick of Pixel XL hardware didn't want to gamble anymore, no more call issues, microphone issues, but now I have ScreenConnect software issue again. I now carry my Pixel XL with me so I can use screenconnect along aside my Note 8...


Trackpad mode, which supports a few touch gestures, was pushed to beta today. We intend to keep this in beta until internal testing is complete...I'd guess that to be a week or so. This new addition may resolve those affected by this bug, if you find not, please let us know. 


If you're interesting in joining the beta, please send a gmail or G-suite address directly to pm@screenconnect.com

Updated to the beta on a Pixel. The trackpad mode does not work at all. Mouse does not move, taps do not register, etc. No function at all. Switching back to the virtual mouse and everything works as expected. Good idea in concept, failure in execution.

Hi Craig,

I will follow-up with you, off this thread, to collect for information. 

I've not had a mouse on Android for as LONG as I can remember (since the old legacy app was replaced), honestly. I've had to use the tap, send click, for months and months and months, over a year. I honestly thought that it was just they PURPOSEFULLY took it away, which made me extremely mad and upset. I have a Note 8, and a Pixel 2 XL. Neither have a mouse. So I don't understand how it can take over 1 year to resolve this issue. And now after reading through these comments and seeing other people who are just as frustrated on the App Reviews on Google Play Store, IT PISSES ME OFF that nobody has fixed this. ConnectWise you have absolutely ruined yourself, and I hope you lose all your customers with it.

I went a year without the ability to use SC on my phone at all - it would open and crash every single time. I've had to keep a laptop with me 24/7. :(  This last build *finally* resolves that problem and includes two separate mouse interfaces - legacy and touch which are toggleable within the interface. Are you using the current build?

Hi All,

A fix was deployed to beta yesterday, see


The plan is to transition this to a PR next week if all goes well.

Fantastic it took as long as I own the Note 8 just in time for the Note 9...

Commenting disabled