0
Under review

Unable to log in after enabling SAML and disabling Internal Authentication

ACG200 8 months ago updated by Stew Ives 8 months ago 1

Self-hosted version 20.13.1633.7620

After enabling and testing SAML w/ Azure AD, I disabled internal authentication. Once I did that I was completely locked out of the server, and clicking the Login button on the main page resulted in a 404 error. I tried resetting the installation and configuring a new default Administrator account, but doing so did not re-enable internal authentication as expected so I still couldn't log in.

Support showed me how to edit the web.config file to re-enable internal authentication in order to log in with the default administrator account. Search web.config for "user.xml" and change the "enabled" value to true. 

After re-enabling internal authentication, Azure SSO started working as well. It appears that disabling internal authentication prevents SSO from working, so for now I have to keep internal authentication enabled even though we want to use SSO exclusively.

ConnectWise Control Version:
Other (please specify)
Server Affected:
Host Client Affected:
Guest Client Affected:
OS:

Do you receive /null 404 Error?  - I get the same thing but only in Safari.