+9
Under review

Queued actions not being processed in v20.11.1372.7585

Simon 6 months ago updated by CFB Computers 5 months ago 16

On my cloud instance, whenever I try to wake a machine with WOL, a QueuedWake action is added as a "Pending Activity" within the General tab, but unlike in previous versions it just stays there without being processed.


It used to disappear after a short while as the wake is attempted by the server. But now, it looks like it's not being attempted at all.

The odd thing is that if a host attempts to connect to that machine, the queued action is suddenly processed. See the attached image. So it seems like there's some bug that holds up the server from acting on the QueuedWake action until a host is connected.

ConnectWise Control Version:
Other (please specify)
Server Affected:
Host Client Affected:
Guest Client Affected:

Okay, I've had more tries and it looks like the workaround I mentioned above (joining as host to process the queued actions) doesn't always work... So there are some machines I'm unable to wake at all right now. Please fix this ASAP.

QueuedReinstall, QueuedGuestInfoUpdate, etc. are also piling up and not being processed. So this bug seems to be affecting the queueing function overall.

Also getting this issue on a on premises install.

I have the same issus on premise install. Please fix ASAP. Thanks

+1

Another problem, can not end active support session on premise install when client connected.

I'm also seeing this after upgrading from 20.9 to 20.11 On-Prem. Support had me refresh the page to troubleshoot but this doesn't change the behavior and I've had computers pending Wake On Lan for 12 hours now. I've restarted the Control server and this seemed to remove all pending activity but the problem still exists.

This seems to be hit-or-miss with various devices, as some Update Guest Info with no problem and others sit indefinitely. I've reinstalled the client from scratch on a few devices (creating a new UUID) and this doesn't seem to resolve anything so I assume it's an issue with the server itself.

Can not "run command" or "reinstall" agent.

Just reverted back to previous version as per advise from chat support.

I have downgrade the server to 20.10.957.7556, now everything works again. I am waiting for a solution with the new version 20.11.1385.7587.

How do you downgrade? Do you just reinstall the previous version with the installer?

Thanks for your help, A.

+1

I have stopped all services. Make a Backup (copy) form Screenconnect dir. (C:\Program Files (x86)\ScreenConnect). Uninstall the Screenconnect (20.11). Install the version 20.10. Stop all services. Copy the following dir/files from backup and override the files."App_ClientConfig\app.config", "App_Data", "App_Extensions","web.config". Start all services. Everything working now. I left the clients on version 20.11.

I followed this and it worked flawlessly, thanks a lot. All commands appear to be working including force disconnections, wake-on-LAN, etc.. I'm looking through a lot of the old commands I executed and it looks like the commands that didn't work aren't showing anywhere in the command pane, but the endpoints the commands did work on are still there, so perhaps the server is failing to write information to the database for various endpoints? Regardless, 20.10 appears to be working.

I know OP said it didn't work for them but in my case upgrading from 20.11 to 20.12.1373.7584 has fixed the issue. Hasn't happened once all day since upgrading this am,tried 20+ updates of screens.  

Please fix this bug soon. I'm on cloud, so I can't easily downgrade my installation like on-premises customers can, but can only revert to a snapshot, which unfortunately means all new logs, extensions, users and some machines will be lost.

THIS IS A MAJOR ISSUE!!!
Why is this taking so long to correct... Please get this fixed on cloud.

+1

I am having "All of the above" problems.  For the first time i have noticed under the General tab it lists Queued commands with option to remove each command by clicking X next to it, haven't seen that before, it does seem to remove the queued commands.  But using the delete all queued commands not working.  Can't update the client info, just spins and spins until you delete the queued command.  The Page doesn't update properly anymore.  In FireFox the pop up Window won't close after successful connection, i have to use Chrome now for that to work and that really upsets me.  I am a FireFox user and have used ScreenConnect with FireFox from Day 1 with no problems (from the Firefox side of things).  Uninstall missing on clients that are offline.  This is just a mess.  It feels like every new version is taking you 2 steps backward and whatever little "upgrades" they're making are not worth the bugs and breaking of things that do work.

FYI this forum thread said they just pushed out an update for 20.11 and 20.12 to fix this issue. 

https://forums.connectwise.com/community/connectwise-control/f/connectwise-control/45647/anyone-else-having-the-problem-with-20-12-where-you-refresh-guest-and-it-just-sits-there-and-spins-and-never-responds-had-the-same-issue-in-20-11-support-told-me-to-go-to-20-12-well-same-problem

Just installed the latest 20.12 on my server, though it was fixed with the 20.11 to 20.12 upgrade for me before.  Everyone else should definitely try this though.