Under review

Server unresponsive in v20.11

Simon 1 year ago updated 12 months ago 3

I've been using the following configuration on my server and it's been working fine until I updated to v20.11.1284.7577. Now all of a sudden the web server becomes unresponsive when configured this way.

<section name=“screenconnect.routing” type=“ScreenConnect.RoutingConfigurationHandler, ScreenConnect.Server” />
<rule schemeExpression=“http” actionType=“issueRedirect” actionData=“https://$HOST/” />
<rule schemeExpression=“ssl” actionType=“forwardPayload” actionData=“https://localhost:8043/” />
<rule schemeExpression=“relay” actionType=“forwardPayload” actionData=“https://localhost:8041/” />

ConnectWise Control Version:
Other (please specify)
Server Affected:
Host Client Affected:
Guest Client Affected:

Has anyone figured out why the ScreenConnect Router service suddenly stopped working with v20.11? I just tried the new stable release, v20.11.1385.7587, but this issue is still not resolved.

I remember there were changes made to the type values in v6, where the "Elsinore" prefix was dropped so that it looks like what I have above. Have you made changes to that bit again, perhaps? Is that why it's not working anymore?

I too have encountered the same exact issue since updating to v20.11.1385.7587. Anyone come up with a solution? If so, please post it here.

I made a post about the bug in the forum as well and over there I received the following reply: