Under review

Waiting to Retry / Negotiating

Sean Keown 1 year ago updated by Simon 3 months ago 1

We've had issues where control will not connect even though nothing is being blocked by the customer or nothing looks blocked. We've worked with support and was told that the connection is delayed enough that it's causing control to not connect.  Is it possible to extend the time at which it takes to authenticate? Example: Ticket# 13700494

The response from our customer is that all other applications including teamviewer / goto assist / zoom and a 1000 other apps work perfectly just fine. How is it our network when only one application is not functioning?

When this happens there are no logs or any way to troubleshoot this issue in control.. It just sits there and says waiting to retry / negotiating.. over and over. 

When testing we tried our hostedrmm.com instance along multiple screenconnect.com instances. 

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

I am experiencing this too suddenly since v21.8 though I’ve never had this issue in previous versions

Is it related to Control using TCP instead of UDP hole-punching like TeamViewer and others? But that’s always been the case, so why now?