Trigger emails not being sent after v20.8.29574.7520 update

Simon 12 months ago updated by Caitlin M Barnes (Product Manager) 11 months ago 15

My cloud instance auto-updated to v20.8.29574.7520 yesterday.

Since then, none of the trigger emails I've set up are being delivered.

I know for a fact that the trigger itself isn't the issue, because I haven't changed the settings.

And just to double-check, I added a Session Event Action ("AddedNote") to the trigger and that's working fine. It's just the Email Action.

I've also checked my spam folder. Nothing there.

My mail delivery method is the default one: "Send from server directly to the email domain SMTP server"

I can't choose a different mail delivery method anyway, because "Send from server through an SMTP relay server" isn't working (that's a different bug, something to do with Advanced SMTP Settings extension).

Only "Send Test Mail" works.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:



This issue has been fixed in build version 20.9.854. The fix version is also available in 20.10, which should be stable next week. 

Thanks for reporting Simon, dev is currently investigating a fix. 

I just upgraded to v20.8.29679.7530. Trigger emails are still not being sent.

Same on the newly released v20.9.680.7530.

Getting some triggers to work, but not all.  V 20.8.29574.7520
Issue may have existed on 20.7 (I was on that version only briefly), but not on versions before that.
A few days ago, wasn't getting any triggers, went to do an email test, then the entire backlog arrived.  Now, some emails come in, others not.  Updated all extensions, no difference.

a further update, went to do another email test, but now getting The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.0 Must issue a STARTTLS command first. k8sm14293972ilk.11 - gsmtp
I did check that 'less secure apps' is allowed on gmail.

using port 587, SSL on.  Tried port 465, burt that test fails with not specific error (failure sending mail).
According to Gmail, 587 is for TLS/STARTTLS, 465 is for SSL


I believe what you're describing is a bug in the "Advanced SMTP Settings" extension. The trigger emails not being sent must be a separate bug, something to do with the software itself, because even when you don't have a custom SMTP server configured (i.e. the emails are being sent from the Control server itself) the emails are still not delivered.

See this bug report:


This is a huge problem.  We can send test emails with no issue but triggers are not working at all.  Created several super simple triggers and nothing.  Appears the entire trigger engine is broken. 

We need some info and an ETA on this.  I was going to upgrade to latest 20.9 but Simon says it is still broken there.  

I've found that the other actions types -- Web Request and Session Event -- are working fine, it's just the Send Email action that's broken. So I believe the trigger is working and is indeed queueing an email, but something is goes wrong after that.

Anyone having issues with clipboard too in these later releases?

I'm having the same issue. 20.9.680.7530

Same issue with Triggers 20.9.680.7530. Not being notified when a guest starts a support session. Would LOVE to have this fixed

We're having the same issue with the email triggers, nothing firing. I'm missing so many client sending us chat messages, it's becoming a major issue. @Joe - Yes, clipboard is a mess which is causing headaches. 

I don’t understand how v20.8 and v20.9 can be designated ‘stable’ when a core feature isn’t working. Triggers aren’t an ‘extra’ feature. It’s a feature that comes with the software, not one that’s provided via an extension. So the software itself is broken. CW should take more time and care with their releases.

Upgraded from 20.8 to 20.9 a few days ago, also noticed that there's an update to the advanced SMTP extension, which I installed.  Triggers worked for a couple of days, then stopped again  :(


This issue has been fixed in build version 20.9.854. The fix version is also available in 20.10, which should be stable next week. 

Commenting disabled