Under review

MacOS Catalina 10.15.3 Black Screen

Matrix 7 2 years ago updated 1 year ago 6

Client updates her MacOS to Catalina ver 10.15.3. I can connect to her session, but all I see is a black screen with the top menu bar of the MacOS with the menu items like the Apple Icon etc. I can also see the mouse moving around and nothing else. Is anyone else experiencing this?

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

Hi Matrix, 

Have you tried asking the end user to uncheck and recheck the screen recording permission box in Security and Privacy? Are you trying to connect via support session or unattended access?

We are trying to connect via a support session. It works on all other versions of Mac, just not on Catalina 10.15.3. I tried unchecking and re-checking the permissions and that made no difference.

I setup a new iMac5K last week. It was running 10.15.2 and I could connect fine remotely via connect wise. After updating to 10.15.4 I can connect but I get a black screen. Under Screen Recording the ConnectWise instance is not there and I cannot manually add it like on Accessibility. TeamViewer is still under Screen Recording. I tried the re-install command from the right click menu. I uninstalled/ended the session but still I get the same issue.


After uninstalling/ending again, I restarted the iMac and the session appeared under Screen Recording and was able to click it.

I noticed something similar yesterday when upgrading a customer remotely.  She had been on 10.13.6 and was connected to my ScreenConnect with the Support client.  After the upgrade I could only see the menu bar and a blank desktop.  Ended up using a different product to finish with her.

Today I set up a new 10.15.4 VM and tested. On the first go round I ended up with the same result, menu bar only.  I had checkmarked the program in Accessibility.  Don't recall seeing any prompt about granting access for screen recording.  When I tried again I did get a prompt for screen recording.  When I enabled that it worked fine.


I don't get the screen to allow screen recording. Is there somewhere in the preferences menu that can allow this?