Advanced Configuration Editor on v19.6 — "Object reference not set to an instance of an object."

Simon 2 years ago updated 9 months ago 19

I updated my cloud instance to 19.6.26188.7290.

On the Configuration page, when I click on any of the four links under 'Web Configuration', I get the following error message: "Object reference not set to an instance of an object."

This isn't the case with the links under 'Application Configuration' or 'Disable Host Client Menu Items'. They're working just fine.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

I fixed your instance. Not sure how this happened, but I've seen it a couple times before. Somehow, one (or more) of the web.config keys gets saved without a "value" attribute.

Were the four web.config menus working properly before you upgraded?

Thanks Eric! Yes, that’s right — they were working fine before the upgrade.

It's happened again...

Fixed. Do you know if this correlates to some kind of change you make to your instance? (An upgrade, a specific configuration setting, etc.)

I'm having the same issue. A big issue because this plugin is how configure Duo MFA: https://docs.connectwise.com/ConnectWise_Control_Documentation/Get_started/Administration_page/Security_page/Enable_two-factor_authentication_for_host_accounts/Configure_two-factor_authentication_with_Duo

Of course, I only need DUO configured in ScreenConnect because of this other year long bug that prevents me from using SAML for several users (Our SAML handles DUO MFA): https://control.product.connectwise.com/communities/6/topics/2228-saml-fails-due-to-too-many-groups

What can I do to get this working?

EDIT: I edited the web.config file and found 3 keys missing the value entry. I've added value and now the plugin works.


Still not sure how this is happening, but the extension will handle it in the next version. (And the SAML fix is slated for 20.3.)

Having the same issue with 19.6. Don't see any web.config keys missing value attribute. There are some keys with value=""

What needs to be changed to fix? Thanks

Do you know if any changes were made recently that might be correlated with this? I put a fix in the next version of the extension, but I'm still curious as to how this happens in the first place.

If you don't mind, I'd like to take a look at your web.config file: edavis@connectwise.com

Having this same issue on my on-prem Screenconnect, fresh install. I'll see if I can find any empty keys iin the web.config and app.config.

Ok never mind, after a reboot of the server it works fine... strange.

I'm having the same issue with an on-premises installation. Upgraded from version 20.7.29443.7508 to version 20.8.29574.7520, and tried rebooting, but still getting the same error.
I don't see any empty keys in the web.config.

Just updated to v20.10.957.7556. Now, this bug appears whenever I click on any of the Client Configuration links. Web Configuration links are fine. So that's the reverse of the original bug reported, which affected only the Web Configuration.

As long as this bug remains, the App.Config Settings extension shouldn't be deprecated so that it can be used as a fallback.

I worked with support, and we tracked down the issue.  At some point, my web.config got slightly corrupted. 

We found that several lines that were normally below my "AsymmetricKey" had been appended to the end of that line, so the software was having trouble parsing one line that contained 4 keys. 

I suspect that it was caused of one of the upgrades making a change to that web.config file, and not handling my 10-year-old config totally perfectly.

Hello, I was directed here from a support ticket. I'm hoping a developer can reach out and help me as well. I'm on version 20.10.957.7556 and I also get the object reference error whenever I attempt to click on any links under Advanced. The only thing that works for me is the Settings link under Web Configuration.

You should reopen your ticket and have someone in the dev team fix the app.config file on your instance, if you're on the cloud. That's what was done in my case. The bug seems to be due to the app.config file being corrupted, which results in this NullReferenceException error being thrown. Until the bug is fixed, the only workaround is to have someone in the dev team manually fix the file. I really hope this gets fixed soon, it affects all new instances deployed on the cloud.

This is working now. Thanks for fixing.

I see that there's a new version of the extension, v1.2.30. The bug still remains, though.

I just tested it out on a brand new cloud instance and both the Application Configuration and Disable Host Client Menu Items links still throw the same NullReferenceException error when clicked on.