+18
Planned

Windows key stuck on host client

Dylan 2 years ago updated 1 month ago 38

Our users occasionally report that the Windows key is stuck on the host computer after using it in a remote control session. Windows will act like the key is still being held even outside a remote control session. Pressing the Windows key a few times solves the 'stuck' key.

Problem can occur after using the Windows key in a remote session to launch Explorer (Win + E) for example.

This problem started to occur after upgrading to 19.0.23665.7058

Host computers are running Windows 10 1809 October 2018 Update x64

ConnectWise Control Version:
20.4
Server Affected:
Host Client Affected:
Guest Client Affected:

Answer

Answer

Hi Cameron,

We have tried replicating this issue on our end but couldn't do it. We have run through following scenarios:

  • Host is connected to active guest - Windows Key works on guest machine if the windows app on the host side is on focus.

  • Host is connected to active guest - Windows Key works on host machine if the windows app on the host side is NOT on focus OR minimized.

  • Host is connected to an inactive guest - Windows Key (kind of gets stuck) as guest has not joined the session yet. Waiting for the guest to join so that Windows Key will be enabled on the guest side.

  • Host is connected to an inactive guest - Windows Key (kind of gets stuck) as guest has not joined the session yet. Minimize OR lose the focus from the windows application to unlock Windows Key.
  • Please observe the behavior. If it reoccurs help us with a screen recording or a call to our support team to report.


    Thanks.

    +2

    This is a huge pain in the rear, please fix.  

    +2

    I have this issue after working in an RDP session and then switching Windows 10 Virtual Desktops Using the WIN + CTRL + Left or Right Arrow.

    It only started happening with the last ConnectWise Control update, it's super frustrating for example if I type letter D all my open windows become minimized equivalent to pressing WIN key + D

    +1

    The problem still persists after upgrading to 19.1.24050.7079

    +1

    This issue still exists on 19.1.24050.7079 Windows Build 1803. If I can upgrade to Build 1903 I will report if the issue still exists here.


    Hi Arussel, thanks for chiming in.

    I'm currently on build 1903 and can confirm the issue still occurs.

    +2

    As Dylan mentioned issue still occurs on Build 1903. I called support yesterday and submitted a ticket. It ended in them informing me that this is a known bug and their Dev. Team is allegedly investigating the issue.

    For those of you who are experiencing this issue because you utilize Windows Virtual/Multiple desktop feature. There are other third party multiple desktop applications that can be used in the mean time (Which can utilize hotkey combinations that do not require the Win Key). I have only tested VirtuaWin. Its not the best but it is very light weight. 

    Is this still being worked on?  

    +1

    I'm having a similar issue only the Control key thinks it is stuck. I dont experience any symptoms as the host but the user can not type, even in the chat box. If they do type and happen to type a letter that has a command associated with it (like P for Print) it becomes problematic.

    Is this still being addressed? Is this related?

    I can confirm that this is still occurring I'm on 1903. 

    I'm driven insane multiple times a day because of this.  What is it going to take Connectwise?  Are you just going to purchase this amazing remote software company and then just let it rot?

    +1

    Still having this issue 1909

    +1

    Well I'm happy I'm not alone, this has been happening for well over a year.  Would absolutely love to get this fixed.  It happens to me everyday.

    +1

    I have been dealing with this for a year as well. Using multiple desktops is crucial to having the landscape necessary to do my job effectively and this is a major pain in the rear. I have several technicians who also experience this as they utilize this W10 feature as well. Curious if anyone has tried not changing desktops during an active session and if that avoids the issue. I am trying to get a work around out to my team.

    Thanks!

    +1

    I've found no work around, I even tried rebuilding my PC and no go.  This started happening to me when the upgrade came out that put the bar at the top that reads " Ctrl-Alt-Del is available to be sent to this device  Send Ctrl-Alt-Del  Dismiss" 

    I wonder if we were able to disable that if this stuck key issue would go away.  I don't think that bar is necessary.  The toolbar can be used to do that.

    Is everyone having this issue using the on premise install?

    the issue lies in the ability to use multiple desktops in W10. When you have a session open and then Ctrl + Windows + left(right) to change desktops is when the issue occurs. I am testing whether I get the same issue if I do not change desktops while actively using a session. Will update later. 

    In our case, it's the Shift key that sometimes gets stuck and at other times it happens with the Ctrl key.

    +1

    This is also a problem for control from a Mac as use of the Mac's Command key is interpreted as the Windows key being pressed and staying "Stuck". I wish either for a fix or that there was an indicator of the current Windows key state. It's risky pressing keys when the Windows key is stuck on in a session and you don't know it. Especially when in the course of troubleshooting a client's problem, you're tasked with reproducing specific steps to evidence a problem. Or trying to avoid disrupting their current setup while performing a necessary driver install, for example.

    +1

    Wow.. it's been a year and this issue is still happening?  Has anyone heard anything about this being addressed at all?  It's extremely irritating.

    +1

    I've been dealing with this issue for YEARS, don't expect a solution anytime soon unfortunately.  Anyone who uses multiple desktops can pretty much expect to be extremely irritated when using Connectwise Control.

    So has it been confirmed that not using multiple desktops stops this from happening?

    +1

    Any update??? Happening on 2004. Extremely frustrating

    +2

    CONSTANTLY - major disruption to productivity!!

    +2

    Awfully telling, isn't it?  ConnectWise doesn't give a hoot as long as we are paying the bill.

    Has anyone figured out a workaround other than not using virtual desktops? ConnectWise has no interest in fixing the issue. It's been two years.

    +1

    i haven't found it and am haunted by this issue every single day.  Connectwise is dead to me.  Long live screen connect. ;(

    Does ConnectWise even read these things? Having a bug open for 2+ years that kills productivity is pitiful for a software company. Why is there even a bug reports forum? 

    +1

    Hi All, just caught up on this thread as I have the same issue on my work desktop. Is there any plan to fix this anytime soon or at least a work around ?

    Answer

    Hi Cameron,

    We have tried replicating this issue on our end but couldn't do it. We have run through following scenarios:

  • Host is connected to active guest - Windows Key works on guest machine if the windows app on the host side is on focus.

  • Host is connected to active guest - Windows Key works on host machine if the windows app on the host side is NOT on focus OR minimized.

  • Host is connected to an inactive guest - Windows Key (kind of gets stuck) as guest has not joined the session yet. Waiting for the guest to join so that Windows Key will be enabled on the guest side.

  • Host is connected to an inactive guest - Windows Key (kind of gets stuck) as guest has not joined the session yet. Minimize OR lose the focus from the windows application to unlock Windows Key.
  • Please observe the behavior. If it reoccurs help us with a screen recording or a call to our support team to report.


    Thanks.

    +1

    You have to use it with virtual desktops. It happens literally every day for me and didn't happen years ago before the update. I will start typing on my local computer and everything will get minimized and windows explorer will popup and every letter I type will act as if I have the windows key held down.

    +1

    Click the task view button

    Create a new desktop

    Switch between them by hitting Ctrl+Win+left arrow or right arrow. Now when you switch between desktops if you have been working in Control, when you go to type on the local computer it will act as if you have the windows key held down. It cripples productivity. Have tried with different hardware, wiping and reloading windows, it is a control bug that has been open for years. 

    Zach,

    I don't even use the Windows virtual desktop feature and still this bug occurs, even with the latest Windows 10 20H2 feature update and ConnectWise Control 2021.3, 2 years have now passed since I first experienced this bug and it still occurs.

    And I note again a simple test -- connect to a Windows machine from a Mac. Press the Mac's command key and watch it invoke the Windows key on the PC. So almost any keystroke combination on the Mac that should be alien to the Windows environment causes disruption within Windows -- cmd-tab to switch applications away from the ConnectWise client, for example.

    Hi Rishikesh,

    Thank you for jumping on and shining a bit of hope on us hopeless strugglers.

    I get this issue everyday single day and it has been doing on for no less than 2 years.  I use multiple desktops in windows 10, so holding ctrl+windowskey+arrow keys left and right to quickly goggle from left to right desktop.

    If I have a connectwise control window open and use that key combination its fine, but as soon as I switch back to the desktop that has the connectwise control window open, the windows key sticks.  So when I try to type in anything, I just get all kinds craziness.  Whiteboards, cortana, onenote, windows settings, emojis, just all kinds of crap at the same time.  Now, if when I go back to the desktop that has the connectwise control window open and hit JUST the windows key, it will not do all that craziness, but if I don't, all hell breaks loose.

    I can reproduce this a million times if you would like to see it in action.  Like I said, its been like this for years, and by the looks of all the other people here, I'm not alone in the frustration.

    Thanks again for hopping on and offering some support.

    Does anyone have any good recommendations for software to replace Control? Preferably software from a company that doesn't sit on bugs for years

    This has caused me untold pain and misery, I'm looking at alternative software as well right now. I will be getting rid of the entire Connectwise Suite (Manage/Automate/Control). I'd rather drive to all my customer sites and plug a monitor and keyboard in then deal with this any longer.