Under review

AMD CPU - no monitors connected - Version 6.9 - blank screen

Sam Segura 2 years ago updated 11 months ago 19

Specs of machine:

Ryzen 5 1600 does not have integrated graphics.  Graphics card: Nvidia NVS 310 (dual display port), only one monitor is being used.

If no monitor is connected to machine, upon starting a session you get a blank screen.  If during a session and you disconnect the monitor, your screen freezes (no changes, mouse moves do not affect image).

The guest stays connected to server

On host page, In Start tab -> Update Guest info, does not change image

On host page, Running a Tool does work (rebooted machine) - Start tab updates, but session image gets to "restarting" and stays there.

Able to RDP into the machine w/o issue.

Plugging a monitor back in, immediately updates the session image and returns to normal functionality.

Unplugging the monitor re-freezes session screen image.  It would appear mouse clicks do get sent to the session - in Host page, Start tab, Update Guest Info updates screen as you click, even though the session screen image is frozen.

This is a similar problem as with other AMD CPUs in the past, with integrated graphics, where if no monitors are connected, while in a session, you cannot change the resolution.  It would appear related to AMD CPUs

Not sure if Guest Client software is affected.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:
Under review

I think that the display driver simply doesn't produce any image if no output device is detected. This is a limitation for any software that performs screen capture - if there is nothing to capture, nothing new is displayed. (i.e. The last captured image persists.)

You can purchase what's called a "dummy plug" for the video card, which simulates a connected monitor and causes the GPU to render the screen.

You might also try switching to a generic display driver as described here: https://docs.connectwise.com/ConnectWise_Control_Documentation/Get_started/Knowledge_base/Blank_screen_troubleshooting

I installed in the latest WHQL NVIDIA driver 392.00 64-bit onto the host machine (Ryzendesk).  Same issue. 

As it cycles through a reboot

Interestingly, there is some image that is capture-able.  The Start tab (in the host page) when clicked Update Guest Info, does indeed update it's capture.

The machine I'm using to access ScreenConnect host page.  I have the latest build of the ScreenConnect client on my machine.

To test:

I changed to the Microsoft Display driver and rebooted

Indeed there is no longer a blank screen and it's accessible in a session.  However, same as before on other AMD machines, Resolution is stuck at 800x600

Thanks for the additional detail; that's helpful. Does the "Update Guest Info" work all the time, or only at certain screens? (ex. the login screen) And to be clear, can you confirm that the desktop thumbnail is continuously updating while the client does not?

If you haven't contacted support already, please do so we can get a ticket on our board. (We've starting tracking reports of this issue.)

e.g. while I have the MS Basic Display driver,

when I am in an rdp session on Ryzendesk, It displays this.:

When I had the nvidia driver installed, it only displayed the white text but with no background.

I'll take a screenshot next time I have the nvidia driver installed

More tests:

MS Basic Display, plugged in monitor, rebooted

Resolution configurable

Remove monitor. Session accessible, resolution still configurable.

Rebooted.  Back to accessible, but resolution not configurable.

Note: on this same motherboard (Gigabyte A320M-S2H) with an AMD A8-9600 (which has an integrated APU) I saw similar behavior

I am able to replicate this issue on my Intel / Nvidia dual screen setup as well. Interestingly, the problem does not occur on virtual machines.

On my home setup if I turn both monitors off and try to screenconnect in, I get no screen or, sometimes, a 640x480 window.

If I turn on at least one monitor, then I get a regular screen display.

If I turn on both monitors, then I get a dual screen display choice

It seems that screenconnect heavily relies upon the graphics driver being used.

Dell Precision T3610, Radeon graphics, Xeon CPU - no issues. 

removed monitor, rebooted.  Was able to change resolution.

Might be chipset related.

We ran into this problem with all of our Lenovo AMD laptops. The issue does not occur with our older laptops that use Intel graphics drivers. So this would appear to be a problem between the screenconnect client and AMD graphics.

Tested on Dell T3610 / FirePro V5900.  No issues.

Operating System: Windows 10 Pro (10.0.17763)

Processor(s): Intel(R) Xeon(R) CPU E5-1620 v2 @ 3.70GHz (8 virtual)

Available Memory: 14522 MB / 16328 MB

Client Version: 6.9.21870.6964

Model : Precision T3610

Manufacturer: Dell Inc.

BIOS Name:BIOS Date: 11/14/18 01:20:02 Ver: A18.00

We tested with AMD Radeon Graphics and AMD Vega graphics on the latest Lenovo laptops. Using Wi

ndows 10 1803 and 1809.

Has this issue been investigated further or a solution found?

Same issue on a Ryzen 3 2200G running Server 2019 Essentials headless.
Client running latest 19.3.25169.7170

Update Guest info returns a valid screenshot 100% of the time and the keyboard inputs work correctly remotely.
No issues with competitors software.

HI.  We are having the same problem.  Guest info returns a valid screenshot 100% of the time and the keyboard inputs work correctly remotely.  Fortunately we had a competitors software on the system which worked.

We're running:

Windows 10 Pro for Workstations (10.0.18362)

Intel(R) Xeon(R) W-2104 CPU @ 3.20GHz (4 virtual) (X64)

NVIDIA Quadro P400, 2GB, 3 Dis playPort (5820T)

Has anyone found a 'software display emulator' that works?  Any suggestions would be greatly appreciated.


We experienced this issue today on 2 identical machines. 

Lenovo ThinkCentre M715q

AMD Ryzen 5 Pro 2400GE

AMD Radeon Vega 11 Graphics (driver version 26.20.11022.3)

Windows 10 Pro 1809 (10.0.17763)

We switched the display driver to the Microsoft Basic Display Driver and Control immediately started showing an image and worked normally. Did the same, with the same result, on both machines.

Any update on this, or a permanent fix?

Thank you Aaron for sharing.  We ended up doing the same.

This definitely needs a fix.  Had we not had alternative way of getting into the machine, it was going to be a long drive.

Oh, and I forgot to mention we're on Control 19.2.24707.7131 (2019.2). Not the latest version, which is 
19.3.25270.7185 (2019.3), but just one release back. 

Were you able to get this fixed? How did you switch to the basic display driver?

Fixed? Nope. Although I don't know if we've encountered this situation again since I posted here 4 months ago. 

We switched to the basic display driver by accessing the computer another way. I don't recall if we used LabVNC (through CW Automate), or RDP, but somehow we got into the system and changed the display driver to the Microsoft Basic Display Driver using the Device Manager.

Still an issue.  Radeon HD 6450 - latest driver installed.  


RDP'd in, device manager, Radeon shows up as hidden
In ScreenConnect session, blank screen.  The "blank / un-blank" toggle does nothing.  But after 5 minutes, restart session get 800x600 resolution.  Cannot see anything after login.