Disabling the HostSessionWithoutConsent security role prevents hosts from connecting to guests

Justin Samsel 3 years ago updated by Eric Davis 3 years ago 5

After upgrading to Windows ConnectWise Control 6.7.19388.6796 I noticed I was no longer able to connect to guests. I spoke with support and we pinpointed a bug that when HostSessionWithoutConsent is disabled no connection to a guest is possible. The connection to a guest attempts to happen but immediately fails.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:
Waiting for information

Are your guests all Windows as well? Could you tell us which version? (Similarly for your server and host.)

I tried to reproduce the issue, but have no connection issues after toggling that permission on my local install.

Yes the guests are Windows. I had tried connecting to Windows 7 and 10 machines with the same result. The server is 2012 R2.

For now I just have HostSessionWithoutConsent enabled so that I can successfully connect to computers. I hope to get to a point where I can start requiring consent again though.

When I spoke with support this morning to pinpoint this issue my chat ticket number was #10929870. If needed I would be able to do a remote session and phone call to demonstrate the issue if that would help.


Thanks. It looks like development is getting ready to release a fix soon. I don't have an ETA, but I believe it is going out in the next week or two.

From the support ticket, I can see you've already been invited to watch our Output Stream topic on the forum, but I'll update here also when the fix is released.

This appears to be fixed now with the latest version. Thanks guys :)

Commenting disabled