Known issue

Firefox Secure Connection Failed - SSL_ERROR_RX_MALFORMED_SERVER_HELLO

DanFL 3 years ago updated by Joshua S Bingham 2 years ago 5

When connecting to my on-premises SSL linux installation of ScreenConnect, Firefox throws an error:

Secure Connection Failed - Error code: SSL_ERROR_RX_MALFORMED_SERVER_HELLO.

The Chrome, IE11 and Edge work fine.  I am using Screenconnect version 6.6.18120.6697, Firefox 61.01 on Windows 10 1803.  The server is working with no issues.

Firefox doesn't seem to even download the certificate.  The page info box shows no details and the view certificate button doesn't work.  The only tag shown is Content-Security-Policy default-src chrome.

Connecting to Webmin on the same server using SSL works as expected in Firefox.  

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

Same here. Using self-hosted linux install. Crippling SSL problems in Firefox and Chrome thanks to lack of support for modern TLS. Please fix.

Chrome works for me, but after turning on legacy SSL.  Otherwise both Firefox and Chrome fail.

I just had something similar happen to me on version 6.9.21027.6898, self hosted on Linux (Fedora 29).

Was working fine last night. This morning error in Firefox only. Chrome worked just fine.

Restarted the service and it started working again in Firefox.

What is going on with the upgrade, I cannot use my product securely without putting in some kind of reverse DNS or proxy or using a less secure TLS browser.

Please release the update, even the beta has some problems; right now after finally getting an SSL bonded and working. I reset the password via the web.config and now every time when I run setup I get all the way to the end and then when I click Finish a time out message comes up.

Anyone have this issue and if so how did you resolve it?

Thank you for reading this.

Commenting disabled