Under review

OSX Blank Dialog Boxes and missing top menu

kevin 3 years ago updated by adam.connor 2 years ago 24 1 duplicate

When controlling a Mac with no keyboard, mouse or monitor attached, the system dialogue boxes on the Mac are blank.  The top menu is also missing.

In the attached example, the grey box should show that I am wanting to update the ipads to the latest iOS.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

Duplicates 1

...in fact all items are blank/black - this is system preferences:

and the right-click menu is also blank

Other times I just get a blank screen with the Bluetooth Setup Assistant...

Waiting for information

Thanks for reporting this issue.

Does this happen with any headless OSX Guest to which you connect?

Is this through a Support or Access session?  Is there a difference in capturing between the two session types?  If an Access session, what version of Java is installed?

Yes, I have two headless and 4 with keyboards, mice & monitors attached. Only the 2 headless are affected.

I have the latest Java (v8 171), but I've also tried connecting from multiple machines with the same result. It's an Access session.

Thanks for that, what version(s) of OSX are the two problematic machines running?

They're on 10.13.4. The ones which work are also on 10.13.4. The only difference is lack of keyboard, monitor & mouse as far as I can tell.

I'm at one of the clients today and plugged a HDMI cable in.  Here's screenshots showing the difference:

With HDMI cable plugged in

No HDMI cable plugged in

As you can see the top menu is missing and the desktop icons are missing...

I've just ordered a dummy HDMI emulator for Amazon to try... I'll update the thread next week...

The dummy HDMI emulators solved the problem

Hmm, very strange and unfortunately I have not been able to replicate the issue internally with a headless mac mini we have.  When you plugged in the dummy HDMI plug, was the issue resolved immediately?  Were you actively connected to the machine when you plugged it in or did you notice it was resolved upon your next connection to it?

Same problem.  Even after a session is connected and no menus are displayed, simply plugging in a monitor with HDMI fixes the display issues in the remote ConnectWise Control session.  This is a problem as I use the Mac Mini in a headless state when on customer site.  I will try an HDMI emulator.  Thanks to Kevin for the input.

I'll just add another case here.

3 Headless Machines with ConnectWise Control Access.

Machines 1 and 2 both suffer from the same graphics issue described above. Some windows are white / blanked out. Others are not. Desktop icons are rendered as one big white rectangle obscuring any part of the desktop that has icons.

Machine 3 has none of the issues and works just fine.

I plugged a HDMI emulator into Machine 2 and a Mini DisplayPort emulator into Machine 1 and now they appear correctly. Plugging the emulators into the machines while an Access session was open resulted in an immediate fix to the graphics. 

The only commonality between the machines is that both that are having troubles are running OS X 10.13.6. Otherwise they do not share any other common factors (processor, graphics card or java). 

  1. Mac Pro 5,1 
    1. 2 x 2.4 GHz 6-Core Intel Xeon
    2. ATI Radeon HD 5770 1024 MB
    3. OS 10.13.6
    4. No Java Installed
  2. Mac Mini 5,3 
    1. 2 Ghz Intel Core i7
    2. Intel HD Graphics 3000 512 MB
    3. OS 10.13.6
    4. Java HotSpot (TM) 64-Bit Server  VM (build 25.171-b11, mixed mode)
  3. Mac Mini 7,1
    1. 1.4 Ghz Intel Core i5
    2. Intel HD Graphics 5000
    3. OS 10.11.6
    4. No Java Installed

I'm having the same issue with no text being displayed on Mac Minis with no display connected. I have just updated to version 6.7.19864.6828 but it is still not working properly.

I'm also having to buy hardware to bypass this problem. I did notice that if you enable remote desktop / VNC in system preferences that everything renders fine, so I imagine ConnectWise should be able to solve this somehow in software. Until then, its dongle or VNC. I'm going to buy these to try https://www.amazon.com/1920x1080-generation-Headless-Emulator-Ethereum/dp/B07D9L39GS

Dude.. Alex.. you are a savior.. I was stressing out on this SAME issue.. I have an old mac mini that was working and upgraded to a new 2018 mac mini (and mojave at the same time) and this bug was KILLING ME!

So, you need to turn on "Screen Sharing" in the "sharing" menu in the system preferences.. then it works..

Dude.. You are awesome...

I have confirmed the same issue with 6.9.21027.6898. I have not been able to test with Screen Sharing enabled as I can't navigate with this issue.  Even opening a terminal session via keyboard commands did not work as I could not see the text.

+1 and I tried the screen sharing and it did not work for me..  was hopeful.  I have over 40 headless units I connect to and all the new ones are having this issue based on the OS 10.14.1 I can't install a piece of hardware on each one.  I happen to have one on my desk and will play around with settings to see if I can resolve.

do we still have no resolution to this?  I mostly have headless systems deployed.  I have found that if there is an apple TV on the network I can "mirror" the screen to it then turn off the mirroring and that will correct the issue as well.  but I can't see sending these $20 "fake monitor" devices to all of these installations. 

As for Alex's fix..  unfortunately on these units permissions are locked as Remote Management is enabled and managing screen sharing and screen sharing can't be enabled separately. 


Having this issue today on a 2012 Mac Mini with CWC 19.0.23665.7058

I'm sure CW already know this, but a bunch of problems occur when a Mac does not detect a display plugged in. This turns off the built in graphics and leaves undesired results like this.

It's relatively simple for me to go down the road and put a cheap Mini DisplayPort to VGA adaptor on this particular machine, but it would be nice to have a solution...... above solution did not work for me