Galaxy note 8 - No mouse

Korey 4 years ago updated by anonymous 3 years ago 25

Currently using latest version of Connectwise Control downloaded from the Google Play Store as of Nov 17, 2017 - Version 6.2.13966.6416

I recently upgraded from a Galaxy Note 4 to a Galaxy Note 8. I was using the deprecated Screenconnect for Samsung app on my Note 4 until I upgraded my phone, and I never had an issue with the mouse printer. After upgrading to the Note 8, I tried the Screenconnect for Samsung app first, and that didn't have the mouse pointer. So I tried the Connectwise Control app, but same problem - No visible mouse pointer.

If I long-press a part of the screen and select the options like Double-click here, that will work. But trying to manage a PC like this is a nightmare. 

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

Good morning Korey,

Thank you for reporting this behavior. We are in the process of re-architecting how the Android app handles when and when not to display the mouse view in a session.

While I'm unable to offer an ETA for this fix/improvement, the feature is currently under development. Please refer to the ConnectWise Control Output Stream for the latest development news, which includes details about bug fixes and product enhancements: http://forum.screenconnect.com/yaf_topics9_Output-Stream.aspx




same issue its terrible


Really hope they fast track this. It's frustrating to not have a working mobile option available.


Any update this is still an issue 


Good morning,

I've updated the status of this thread to started, as development has begun the process of implementing a feature that should eliminate this and many other "no mouse on Android" issues. While I'm unable to offer an ETA, I can say that this feature is under active development and has been assigned a high priority.




I can't wait! I've been dealing with this since the middle of September!

Hi Ben, do you have an ETA yet for a fix for the Samsung Note 8?


I am also experiencing this same issue.  Able to view remote computers and send keyboard input, can even move mouse pointer around, but unable to send mouse clicks at all.  I also suspected it was an issue with the older ScreenConnect app, both have the same results.  What is the ETA on this?


Good morning,

We're wrapping up a substantial revamp to the Android app and hope to have a beta out soon. We expect the revamp to eliminate the vast majority of issues related to the virtual mouse. Please refer to the Output Stream for the latest news on the Android app going forward:





This is not working for me either STILL :-(


Here's the latest release log, updated 6 days ago, for the Android app:

  • Updated the Android App UI to reflect the latest product branding changes

That's nice and all, but can we get a solution to this virtual mouse issue? It's been going on for far too long at this point. I originally posted this thread 4 months ago now. Really, Connectwise?

Many of us probably rely on the mobile Control app for rapid support purposes, especially given that the Labtech/Automate program is such a bear to open or keep updated. 


wait for so long time no mouse for samsung note 8.

5 months to fix such a vital aspect of the app is UNACCEPTABLE! the app is useless without it.


really need a fix please... I was running old version of screenconnect and it worked fine until today when Orea came and now the Adroid app has lost the mouse again and the old screenconnect has become black screen and no display.. please help us..its quite urgent. Thanks


Trackpad mode, which supports a few touch gestures, was pushed to beta today. We intend to keep this in beta until internal testing is complete...I'd guess that to be a week or so. This new addition may resolve those affected by this bug, if you find not, please let us know. 


If you're interesting in joining the beta, please send a gmail or G-suite address directly to pm@screenconnect.com

A long click will open menu to left or right click, but otherwise doesn't really work on my Note8.

When will this issue will be resolved? It's been 6 months.

Looks like it's not in plan to fix it. Though you cab 8 use leagect apk but will not let you choose session on Remote computer 

Hi All,

A fix was deployed to beta yesterday. The plan is to transition this to a PR next week if all goes well.

Can someone post link to beta please?

You can grab the APK here

Commenting disabled