Not a bug

Waiting for an available slot...

Xestrix 4 years ago updated by Antony Sanson 3 years ago 3

WI am having an issue where a certain client's machines will not connect to either Access or Support sessions. The status window will alternate between "Connecting..." and "Waiting for an available slot...".

As the host, I get an alternating black screen and "Waiting for your guest...". I have uninstalled the agent completely, tried running as both Access and Support sessions, same issue. I have verified that the network is stable, and resolves our relay just fine. I also verified that we had plenty of concurrent sessions still available. 

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:
Waiting for information

Good afternoon,

The "Waiting for free slot" message occurs when a guest attempts to connect to a session when another guest is already connected. Were the machines where this occurs by any chance created from an image?

One troubleshooting option would be to stop the client service on one of the affected machines, and manually change the session id in the registry:

1) Stop the client service on the guest machine

2) Navigate to the following location in the registry, where the x's denote your server's public thumbprint: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ScreenConnect Client (xxxxxxxxxxxxxxxx)

3) Double click the ImagePath key; it's value should look something like this (truncated):

"C:\Program Files (x86)\ScreenConnect Client (xxxxxxxxxxxx)\ScreenConnect.ClientService.exe" "?e=Access&y=Guest&h=localhost&p=8041&s=ba9400cb-9f42-427e-a379-464ad741a687..."

4) The value ba9400cb-9f42-427e-a379-464ad741a687 in the above string denotes the session id; modify this from it's current value to a different valid GUID, e.g. cd3500cb-9f42-427e-a379-464ad741a687

5) Start the client service on the guest machine -- you should see a new session on your host page with the new session id from step 4.

If you continue to experience this issue, it may be best to submit a ticket with our support team so that they can conduct more in-depth troubleshooting in you environment.



Not a bug


I am suffering exactly the same issue. Tried all the solutions above without a result.

One thing I notice none of the 6 machines I am having the issues with install the client showing the system name as required by the client installer options, could this be the reason for the problem. Why would the installer not show the client system name just the organisation name etc.

They are on a network behind a Office block WAN router and then another router for the internal Office LAN, could this also be a factor?



Commenting disabled