0
Not a bug

macOS Connect does not work

SteveS 3 years ago updated by Caitlin M Barnes (Product Manager) 4 months ago 12

CW Control does not work at all in the recent versions of macOS High Sierra. There is no menu bar, and you cannot quite the program gracefully.  The only option is to force-quit the app.  This has persisted through the last two public betas. 

ConnectWise Control Version:
1
Server Affected:
Host Client Affected:
Guest Client Affected:

Answer

Answer

The behavior described in this thread is not unique to ConnectWise Control; there have been multiple other reports that this behavior intermittently affects Java applications on macOS High Sierra beta builds, and, as such, is an unresolved bug with how the operating system interacts with Java.

Good afternoon,


I have registered an issue with development regarding this report; however, it would be very helpful if we could schedule a session to your environment to observe and gather additional information about the anomalous behavior. I will follow up with you in a moment with contact details.


Cheers,

Ben

Answer

The behavior described in this thread is not unique to ConnectWise Control; there have been multiple other reports that this behavior intermittently affects Java applications on macOS High Sierra beta builds, and, as such, is an unresolved bug with how the operating system interacts with Java.

+1

Hi Ben, 

High Sierra OS has been out for some time now and still no known solution? Does ConnectWise Control have any updates available on resolving this issue or an ETA for when a solution may be available?

I am having the same issue and my Mac OS High Sierra is not a beta build.

+1

I've been having this same problem with ConnectWise Control since we updated to High Sierra. We're on the latest release 10.13.5 and the latest version of ConnectWise Control 6.6.18120.6697 and the issue still persists. Our Macs still running Sierra work perfectly fine. High Sierra machines show the updated content in the preview window but once connecting through the access panel we are greeted by a blank black screen only. 

+1

I upgraded to high sierra today, updated all the way and screen connect stopped working.  No other program was affected, just screen connect.  I want to jump all in with screen connect for our company, but things like this make it really hard.

+1

Connectwise control doesn't seem to work on any of my macs that have high sierra upwards.  Tested on 10+  It's a shame as it could see them losing my business.

I don't care if it's a bug or not, if your software doesn't work with the current OS you should stop advertising that is supports it to waste people's time and damage your reputation.  Apple and Microsoft make arbitrary changes to their operating systems all the time you just have to find a way.

+1

I have the same issue with Mac OS Mojave on one of my clients computer. And with having a new client who is almost entirely Apple workstations this worries me allot that after a year there is still now solution for a known issue. 

Same problem mouse is off by 2" in MacOS Catalina 10.15.3

Any update on this? I have ScreenConnect ver 20.3.28091.7419 and can connect, I see the Mac menu bar, but no screen below that. Just a black screen.

Hi infoworkz, 

Have you made sure the endpoint has allowed ConnectWise Control in both screen recording and accessibility permissions? More info on that here. I'm a Mac user myself, currently on Catalina, 10.15.6, and have no problem controlling this machine from other devices. 

Commenting disabled