After doing a reinstall on Mac clients to v6.3, the screen is black on trying to reconnect

joshthree 4 years ago updated by riclewallen 2 years ago 36

This happens if I do a reinstall from the backroom or if I re-run the package installer on the client.  After the client is updated to 6.3 the screen is black when I try to reconnect.  If I restart the computer, everything comes up just fine.  I've been going to menu: Miscellaneous...Reboot and Reconnect...To Normal Mode.  I've updated 20 clients so far and it has happened to every Mac client so far (about 15 of them).  The PC clients work fine. The version I'm updating from btw is 6.1.  I have a lot more to update, but thought I would hold off until I heard back.  

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:



Client upgrades from 6.4 -> 6.5 should not encounter this issue.


Good morning,

Thank you for submitting this information. I was able to replicate the issue you described and have registered an issue with development. The issue is currently under investigation.

I will update this thread as more information becomes available.




I wanted to provide a method of working around this issue that does not depend on rebooting the guest machine. You will need your server's public thumbprint (see step 2 below for details on how to get this info).

1) Upgrade the Mac client to 6.3.13466

2) Run the following command on the Mac guest from the host page commands tab to obtain your server's public thumbprint (this is the string of letters and numbers in screenconnect-<thumbprint>, e.g. d85033b315c20451 in screenconnect-d85033b315c20451): launchctl list | grep screenconnect

If the Mac guest user is currently logged in, do this:

a) Run the following command on the Mac guest from the host page commands tab, and make note of the output: stat -f "%Su" /dev/console
b) Run the following command on the Mac guest from the host page, substituting in the output from the last command where indicated: id -u <username outputted from last command>
c) Run the following command on the Mac guest from the host page, substituting in the output from the last command where indicated and your server's thumbprint: launchctl asuser <numeric user id output from last command> launchctl unload -S Aqua /Library/LaunchAgents/screenconnect-<server thumbprint>-onlogin.plist
d) Run the following command on the Mac guest from the host page, substituting in the output from the last command where indicated and your server's thumbprint: launchctl asuser <numeric user id output from last command> launchctl load -S Aqua /Library/LaunchAgents/screenconnect-<server thumbprint>-onlogin.plist
e) Reinstall guest client

If the Mac guest is on the login screen, do this:

a) Run the following command on the Mac guest from the host page, substituting in your server's thumbprint where indicated: launchctl unload -S LoginWindow /Library/LaunchAgents/screenconnect-<server thumbprint>-prelogin.plist
b) Run the following command on the Mac guest from the host page, substituting in your server's thumbprint where indicated: launchctl load -S LoginWindow /Library/LaunchAgents/screenconnect-<server thumbprint>-prelogin.plist
c) Reinstall guest client


I think you'll agree, it's easier just to restart :)

We have 30+ server clients which we cannot easily restart so I don't agree joshtree. ;)

@Ben Burner the fix sadly only works 50% of the time... :(

Are there any other ways to bypass this serious bug...

Also Ben Burner we see a black screen so how should we know if the client is in loginscreen or not?


Good morning,

The first command outlined above (stat -f "%Su" /dev/console) should return "root" if the guest Mac is sitting at the login screen. If a user is currently logged into the guest Mac, the same command should return the username.



Awesome Ben, thanks! :)

But still the fix only woks half the time and there is no patern, we have 10.9 clients and 10.10 that don't respond to the fix.

Executed it several times on those clients.

Are we out of options?

I even have one 10.6.8 server that keeps working fine... lol


Good morning,

The fix for this issue should be included in the forthcoming release of ConnectWise Control, version 6.4.

In cases where the aforementioned potential workaround does not resolve the issue, you will likely need to reboot the Mac guest post-upgrade in order to regain control of the machine.



This problem still exists in 6.4! Just updated our server and the client, plus a restart and the Mac screen is still blank.

Just curious, what version were you updating from?

From V6.3.13446.6374

Ugh.  Thanks for the udpate.


Client upgrades from 6.4 -> 6.5 should not encounter this issue.

What about if I'm going from 6.3->6.5?

Still happening in 6.5. These commands do not work for me.

I am having the exact same issue.  I have roughly 20 clients that are just black screens and on 6.5.  Even restarting the machine isnt resolving a majority of the time.  This is frustrating.

Can anyone confirm if this issue is still happening in 6.6?

Just upgraded three Macs, 2 x 10.11 and one 10.12 from 6.3 to 6.6. No problems so far.

Will report back when we do the other 30+ machines

@Absolute, were those Macs previously doing the black screen?

No, they were fine under 6.3. I think we reinstalled SC on the few original  machines that had the problem.  

still happening in 6.6

Hold on, I just ran the commands from Ben Burner and upon reinstall I was able to get it working.

Note this is a 10.12.6 Mac, no java installed.

So maybe CW can finally fix this? What gives?


Still having this issue on

Mac OS X (10.13.6)

Client Version:6.7.19388.6796

"fix" discussed above DOES NOT WORK

Support rep suggested installing Java

Didn't fix it.

Come on, guys! You can't test your software on a Mac before you release it?!

Same issue.  Mine works about 75% of the time.  I have dozens of remote clients, it sucks when they are paying me to do something but yet I cannot even remote in to resolve.   My business is growing, this product is fantastic, when it actually works...

Having the exact same problem on a Guest mac with 10.14.5. Why is this not fixed??

Are you guys ever gonna fix this? Thank Gawd I kept my 6.1.12292.6236 screenconnect server online as its the only way I can access mac. Now I pay monthly for a service that won't work with mac. Connectwise has always been a huge disappointment. Conectwise sucks.

I moved to SaaS last year and black screens nearly disappeared, but over the last couple of months, I am getting black screens on nearly half of a few hundred Macs. I've been elevated to engineering. Again. On Control 19.4.25759.7247

I can sometimes gain control by restarting the LaunchAgent as the user as Ben Burner explained in this thread 2 years ago, log out and in, or restart, or killall -HUP WindowServer but it doesn't always work.

I really wish this could get fixed.

I am hearing other Control users having problems with the 19.4 upgrade. I hope they get this fixed. Once and for all.

We're getting problems with some Macs updated to the latest (19.4.25759.7247) version.

No real consistancy as in a few cases they are identical Macs with the same OS

Worked fine on 19.4.25699.7240 and now we get a Black screen but can move the mouse and theoretically control the remote machine.  If we log in via Apple Remote Desktop, then sometimes it allows ScreenConnect to work. 

Makes no sense at all!

Running 19.4.25759.7247.   100% of my 25+ macs, if the user is not logged in, I get a small (2") grey square, cannot get to login screen. I could restart, but that is a pain.  All of my clients have splashtop client installed.  I did this when control was new and not as robust.   I can log into splashtop, log into client machine.  Once logged in, I can usually go back to control, double click and I am in. 

As everyone has mentioned, this is an incredible pain and impact to workflow.   I know catalina has caused many problems, but they are generally well documented and once the permissions are set properly, you can get in....but not if the user is in a screen lock condition.  Splashtop has figured it out.  Why can't control???

Is anyone at connectwise working on this seriously?  Any insight welcomed

I too get a blank screen when I connect to macOS access sessions. I've also noticed that the thumbnail on the host page is non-existent.

But I've got it to work by closing the host client after I get the blank screen, then connecting to the session again. I'm able to see and control the remote device and when I refresh the host page the thumbnail is displayed properly.

Hi riclewallen, 

Did some testing on my Catalina machine against our stable 19.5 release and didn't encounter the grey square when attempting to access the login screen -- was able to access and remotely login with no problems. I tested both with a locked machine and logged out machine with the same positive result. Suggest updating to the latest stable release to see if that fixes your problem. 

If you're not comfortable with updating your production instance, feel free to create a new trial instance on your account at cloud.screenconnect.com to see if 19.5 fixed your issue. 



It appears the latest 19.5.25928.7265 is better but I still get some black screens, even after closing and connecting again. these computers all accessible via VPN + Apple Remote Desktop (VNC) and in many cases VNC connections actually trigger the CW Control to work. It is such a shame Control is unreliable on the Mac, because when it does work it keeps connections during Migration Assistant and Setup Assistant (new user setup), running Commands is also pretty slick.

Hello all,

  I am on the hosted version of connectwise control.  It was upgraded sometime around the time Catlin's message came out. Since then, I have accessed 3 other machines and found CW is working properly, no blank screens.  Most of my clients are PCs so I have not had time to do a lot of testing, but these three machines were 100% troublesome and now they are acting much more normally, for which I am grateful.  I don't have any insight for kginger as I did take any steps directly. 



Commenting disabled