0
Not a bug

6.1 with ShowFeedbackSurveyForm=false does not prevent survey popup

isaacg 3 years ago updated by Ben Burner 3 years ago 3

Here's my app.config. I've stopped and restarted all three services and the issue persists. Confirmed with someone who is having the same problem. Also the survey setting does not show up in the Edit App.Config Settings extension, don't know if that's related or the extension just doesn't support it yet.

<?xml version="1.0" encoding="utf-8"?>
<configuration>
<configSections>
<section name="ScreenConnect.SystemSettings" type="System.Configuration.ClientSettingsSection" />
<section name="ScreenConnect.UserInterfaceSettings" type="System.Configuration.ClientSettingsSection" />
</configSections>
<ScreenConnect.SystemSettings>
<setting name="AutoConsentIfUserProcessNotRunning" serializeAs="String">
<value>true</value>
</setting>
</ScreenConnect.SystemSettings>
<ScreenConnect.UserInterfaceSettings>
<setting name="ShowBalloonOnConnect" serializeAs="String">
<value>false</value>
</setting>
<setting name="SupportShowBalloonOnConnect" serializeAs="String">
<value>false</value>
</setting>
<setting name="AccessShowBalloonOnConnect" serializeAs="String">
<value>false</value>
</setting>
<setting name="ShowFeedbackSurveyForm" serializeAs="String">
<value>false</value>
</setting>
</ScreenConnect.UserInterfaceSettings>
</configuration>
ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:
Waiting for information

Good morning,


You shouldn't need to restart the Relay, Web, and Session Manager services for the updated app.config settings to take effect; however, you will need to reinstall the client on the machine from which you are hosting before the updated settings take effect, since the ShowFeedbackSurveyForm setting applies host-side only.


If you're using ClickOnce to join as a host, you'll need to close all open client windows, open a command prompt, and enter the following command to clear the ClickOnce cache:


rundll32 dfshim CleanOnlineAppCache


Furthermore, the next iteration of the Edit App.Config Settings extension should include an option to toggle ShowFeedbackSurveyForm.


Please update this thread if you are still seeing the feedback survey form after having taken the aforementioned actions.


Regards,

Ben

So far so good, thanks for the additional instructions. Edit App.Config Settings extension has also been updated, I see.