0
Not a bug

Turning off Survey turns back on Hiddentrayicon

Erik van Putten 4 years ago updated by Ben Burner 4 years ago 3

To my horror i found out that turning off the Survey in the appconfig settings turns the HiddenTrayIcon back off. And now all my clients show the icon....


I also see no Connection banner at the top for these clients when connecting....

(the balloon help shows the connection although)


This is in the stable release 6.1.12292


Erik

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

Answer

Answer
Not a bug

Thanks for updating this thread.


I'm happy to hear you're up and running.


Cheers

Waiting for information

Good morning,


Would you mind posting the contents of your app.config that produces the behavior described above?


I used the following app.config and 6.1.12292 client/server and found that this prevented the appearance of the feedback survey and hid the system tray icon after reinstalling access clients:


<?xml version="1.0" encoding="utf-8"?>

<configuration>
<configSections>

<section name="ScreenConnect.SystemSettings" type="System.Configuration.ClientSettingsSection" />
<section name="ScreenConnect.UserInterfaceSettings" type="System.Configuration.ClientSettingsSection" />

</configSections>
<ScreenConnect.SystemSettings>

</ScreenConnect.SystemSettings>
<ScreenConnect.UserInterfaceSettings>

<setting name="ShowFeedbackSurveyForm" serializeAs="String">
<value>false</value>

</setting>
<setting name="ShowSystemTrayIcon" serializeAs="String">

<value>false</value>
</setting>

</ScreenConnect.UserInterfaceSettings>
</configuration>


Cheers,

Ben

Hi Ben, immediately after seeing your reply i realized my mistake.


I pasted the added text after the </SceneConnect UserInferfaceSettings>

(Instead of before it)

The program does not crash because of that but the result is that everything in the section is ignored.....


Sorry about that. On the other side we now know that the program behaves like this, good to know.

I've also corrected and explained my mistake on the forum.


Cheers,

Erik

Answer
Not a bug

Thanks for updating this thread.


I'm happy to hear you're up and running.


Cheers