+1
Fixed

Remote control shows a black screen, instead of the users screen

Erik van Putten 3 years ago • updated by vanilla 1 week ago 19

Hi since the new client 6.1 I have a system that shows a black screen when being taken over.

The system worked fine with client version 6.0


I've reinstalled version 6.0 no problem.

Reinstalling version 6.1 and the black screen is back.


The client can see my mouse moving when I move it (i can't)


The PC is an Intel Probook G1 laptop with an Intel graphics card and Nvidia as well.

OS Windows 10

Intel HD driver 20.19.15.4483


Kind regards,

Erik.

ConnectWise Control Version:
Server Affected:
Host Client Affected:
Guest Client Affected:

Good morning Erik,


Thank you for reporting this. If you temporarily disable either the Intel or Nvidia display adapter, does the 6.1 client continue to show a black screen upon connect?


Which build of Windows 10 is installed on the endpoint?


If you'd like, please email extension@screenconnect.com to arrange a support session to the afflicted machine in order for us to conduct additional troubleshooting.


Cheers,

Ben

Hi Ben,


I have a machine (laptop) with these graphic cards :

  • Intel HD Graphics 3000
  • AMD Radeon HD 7650M

The client version is 6.1.12292.6236


When trying to connect, the remote support client gives a black screen. Only mouse gestures are passed true to the remote computer.


Blanking out the screen doesn't solve the issue.


Disabling the AMD Radeon HD 7650M device allowed me to see the remote computer.


If you would like, we can setup a remote support session.
That way you can debug as much as you want.


Have a great day!

Bjorn

Good morning Bjorn,


Thank you for updating this thread. What operating system is installed on the laptop in question? Does the laptop have an external monitor attached to it?


Regards,

Ben

Hi Ben, it's the latest version of Windows 10 version 1607

Version reported by Screen connect : 10.0.14393

I need to get the customers permission before I can try disabling the graphics cards.


Regards,

Erik

Erik,


I was able to reproduce the black screen issue reliably after installing the 6.1 client on my dual-gpu (Intel/Nvidia) Windows 10 laptop (I can connect to the dual-gpu laptop without issue using a 6.0 client). I have updated our internal bug tracker with the details and have moved the issue to development for review.


I was able to view and interact with the guest endpoint via the 6.1 client after I disabled one of the display adapters on my dual-gpu laptop.


Regards,

Ben

Ben, great that you can reproduce.

Cheers, Erik.

Hi Erik,

Just to add to this, we have this problem on 6.0 Mac clients. Not every time, just periodically. Usually it's after a reboot or software update.

Nothing major but wanted to make you aware.


Regards,

Ollie








How is this fixed Ben?

This is not fixed on Win10 running SC ver. 6.5.16479.6613

I agree with Jonathan, I still get the black screen. I am trying to connect to a win 10 running in Paralles on a Mac.

This is not fixed. I am running to a problem a CAD machine with 2 GPU.

AMD Radeon HD 8790M (Drivers up to date)

Intel HD graphics 4600 (Drivers up to date)

sc client ver. 6.5.16479.6613

Windows 8.1 Pro (6.3.9600)


Disabling ADM Radeon seems to temporarily fix the problem, but messes with the customers monitor layout and returns on reboot.

Same issue here with 3 different PCs running AMD graphics.


AMD A8-7410 APU with AMD Radeon R5 Graphics

Still happens. Multiple different NVidia graphics cards. In some instances it's not possible to change the graphics as the system is running NVidia Mosaic in a multi-screen setup.

We have this issue also, different versions of client SC, different OS, Win7 x32, x64 and Win10 (various updates), different hardware.  The issue is not widespread enough for us to find commonality.

Happens from time to time, not constant, not consistent.  The usual fix has been to simply connect and reboot the remote computer into normal mode, works most of the time, but is not a desired solution.

I have the same issue. Could you kindly explain what you mean by normal mode?

Regularly get black screen. I think it is mostly on clients with 2 graphics hardware, especially like laptops that can auto-switch to low-power gpu when on battery, and hi-power gpu when plugged into power .  At least on Macos, the 6.1 client seems to "Require High Performance Graphics" **even** when on battery.  That according to Utilities -> Activity Monitor -> Energy.  Using gpu eats battery on laptops. For folks wanting to save battery life, they can stop google-chrome from using gpu very easily under Settings, Turn off "Use hardware acceleration when available". Is there a way to do so for sc client? Like is there a command-line argument to start sc client in such a way as to disable use of gpu? (I could not find any info at all). I have a feeling the black screens are related to this issue.