+1
Waiting for information

Session sub-groups not searchable in 20.2.27038.7359

justin 7 months ago updated 3 months ago 9
ConnectWise Control Version:
20.2
Server Affected:
Host Client Affected:
Guest Client Affected:

Example - PC 'test' is in root group 'ABC' and in sub-group 'ABC-PCs'. So it is visible from both groups. Searching 'test' in 'ABC' finds the PC as expected, searching 'test' in 'ABC-PCs' shows no results (even though PC is clearly visible in the subgroup)

I could not reproduce this (used a simple group with only the subgroup set to GuestOperatingSystemName). Do you have an example filter that I could try?

Waiting for information

Groups are built like this:
Session filter: CustomProperty1 = 'ABC'
Subgroup Expressions: IIF (GuestOperatingSystemName LIKE '*Server*', 'Servers', 'PCs') + ' - ' + CustomProperty1, GuestOperatingSystemName


Any search at all in a subgroup finds no results.

I assume it was a bug with the pre-release as I've never ran into this before, support advised I post here, but perhaps it is specific to our instance..

I used that same subgroup but it seems to work on our 20.2.27038.7359 test instance. (Although it doesn't show the other subgroup as one of the possible locations for the matching machine.)

I downgraded to stable and the issue went away. It's not a huge deal, and it could just be a quirk with our instance.

We have the same issue. This is our sub-group filter IIF(GuestOperatingSystemName LIKE '*Server*' , 'Server', 'Workstation')

We are having the same error.  We’re running 20.1.  

Still an issue as of 20.7.28837.7465