0
Under review

ConnectWise Control Cloud Account password reset link never sends email

effigy345 11 months ago updated by Eric Davis (SDT) 11 months ago 6

I have attempted to reset the password to my CW Control cloud account several times over the last few days.  Each time, it tells me to check my email for a reset link, but one never arrives.  I've verified that the email address for my account is accurate.

ConnectWise Control Version:
10
Server Affected:
Host Client Affected:
Guest Client Affected:

My account email address was the same as it is here.  In order to test if this was the cause, I changed it from an @gmail.com address to an @outlook.com email address, which still resulted in the forgotten password link from ever getting emailed.  I have since changed my account email address back to the same as this forum.  I should note that I have access to my account right now.  I merely was looking to test if a password reset allowed me to get past the TFA on my account.  I'd like to know how to regain access to my account should I ever lose the password or if Google Authenticator ever stops working for me.

On a side note, I did figure out a way to reset the password.  If I click the forgot password button from the login page of my cloud account site, I never receive the email to reset my password.  However, if I click the forgot password button on cloud.screenconnect.com, the email does get sent.  So I guess my question needs to be revised to ask why the forgotten password button doesn't send an email when clicked from my cloud account login page.

Ah, I thought you were referring to the cloud account (cloud.sc.com) site, but you're actually not getting emails from your instance reset requests.

I just tested mine and it worked as expected. Did you have a support ticket associated with this issue?

I do not.  I'm new to using CW Control, so since I'm just testing it, I'm only using the free account at present (I'm evaluating if I want to buy or not).  Since I only have a free account at present, I am not permitted to create support tickets.  I'm not permitted to contact support at all until after I sign up for a paid account, which I don't want to do until I've evaluated everything.  Quite a catch-22.

I checked your settings, and you don't have any instance users (Administration -> Security -> Internal users). When you login as Cloud Account Administrator, that user is "external" to Control, and so resets only work through the cloud.sc.com site (as you saw). The reset link on your instance page (<your instance name>.sc.com) only works for internal users.

That makes sense.  And thank you for clarifying.  To be honest, I didn't understand that internal and external accounts were a thing.  Is that outlined in the documentation somewhere?

You're not alone - this has caused a lot of confusion, so in the next release, we're just disabling the "Forgot password?" link on the instance login if there aren't any internal users present. (It also won't say "Email sent" when there isn't a user (and associated email address) to send to.)