+1
Waiting for information

update process needs improvement

afoadmin 2 years ago updated by Eric Davis 2 years ago 5

The upgrade process is very bad.

If I start a session and an upgrade is available I get a notification to upgrade.  So I click ok to upgrade and always get errors because a session is already in progress so I have to hopefully remember to upgrade later which I never do.  So now I have to write a note to do that after the session and when I do I have to uninstall the old application and start a new session to install a new one.  That process is very cumbersome and there are way too many things to do.  This last upgrade to 6.7 was even worse.  Instead of just getting the normal error, I got a prompt that Windows could not find app  778dcbcf050d08ef and wanted me to look in the microsoft windows store which of course it could not find.  Worst upgrade process ever.

ConnectWise Control Version:
20.1
Server Affected:
Host Client Affected:
Guest Client Affected:
Waiting for information

Do you have any more details about the errors you see when you try to upgrade? And can I assume you're on Windows 10?

Windows 10.

I would think that the errors are easily reproducible.

Just have someone start a support session after an upgrade is released.

I will have to wait for another upgrade in order to give you exact errors.

I can't use the software anyway because the last upgrade broke it.

I have multi-monitor system and the last upgrade broke the monitor selector.

I haven't managed to produce an error message so far. It sounds like something was broken during installation to begin with, especially since I haven't heard about an issue like this before.


Have you contacted support? https://www.connectwise.com/services/support

(This forum isn't ideal for interactive troubleshooting, which is what it sounds like this problem needs.)

I started with support.

Apparently support has noticed the same problems I have that you have not.

Here is the applicable chat session:


10:57 AM - afoadmin@afo.net: also ... the upgrade process is very bad
every
upgrade I get a notification to upgrade when I start a session so I
click ok to upgrade and always get errors because a session is in
progress so I have to hopefully remember to upgrade later which I never
do and so I have to write a note to do that and when I do I have to
uninstall the old application and start a new session to install a new
one ... very cumbersome and way too many things to do. This last time
was even worse, instead of just getting the normal error, I got a prompt
that it could not find the app and wanted me to look in the microsoft
windows store which of course it could not find

11:00 AM - lslater: That is something I have noticed so and will add a
link where we can add a bug report for that as I do not see one listed
already.

https://control.product.connectwise.com/communities/6-bug-reports

I asked the support agent in question, and it sounds like he may have misunderstood your problem. (Or maybe I'm misunderstanding it.)

Please try support again, and include a link to this thread. Emphasize the fact that you see error messages when you try to upgrade. They might start a support call with you to look at possible installation/configuration problems.