+9
Fixed

IOS App Continually Asks for Password

Michael M 2 years ago updated by Eric Davis (SDT) 1 year ago 10

I'm running IOS 12 and version 2018.2.19209.0 of the ConnectWise Control App.  When I open the app I am prompted for my username and password.  I am able to browse to a client and connect with no issues. Once I disconnect from a client I am prompted again for my username and password. 

I must constantly re-authenticate if I want to connect to multiple clients, or even reconnect to the same client.

ConnectWise Control Version:
1
Server Affected:
Host Client Affected:
Guest Client Affected:

Answer

+1
PINNED

If the app is requiring you to log in repeatedly, please try removing and re-installing the iOS app to clear any stale cookies. This should resolve the issue until our official fix is released.

If this doesn't fix the problem, please contact support so we can take a closer look at your particular case.

As always, please don't forget to include in your report the version of your Control server, app, and iOS.

Waiting for information

Do you have the same problem with the latest version of the app?

(Also, if you haven't done so already, please contact support for faster service: https://www.connectwise.com/services/support)

We have the same issues also on both iPhone X and iPad Pro

Server side version = 6.8.19746.6816

same issue here. 

iOS 12.0.1

Control app up to date. 

Self hosted server version 6.3......

When closing a remote session I get an error 95% of the time. 

It says an unknown error has occurred.

With 2FA it’s a pain having to log back in again as it won’t remember to trust the device!

Same here.

This happens since the upgrade to iOS 12 (and now 12.0.1)

Control app at the latest version (2018.3.19272.0)

Self-hosting server version: 6.8.20124.6845

As mentioned, it happens when you disconnect from a remote session (with a few exceptions). Box pops up saying Unknown Error and requires reauthorization, including 2FA.

Apologies for the issues. We're still trying to reproduce this on our own iOS devices, but I've gone ahead and registered a defect given the number of reports, and we're reviewing our authentication code.

+1
PINNED

If the app is requiring you to log in repeatedly, please try removing and re-installing the iOS app to clear any stale cookies. This should resolve the issue until our official fix is released.

If this doesn't fix the problem, please contact support so we can take a closer look at your particular case.

As always, please don't forget to include in your report the version of your Control server, app, and iOS.

Thanks Eric. 

Self hosted Server: 6.8.20068.6842

IOS 12.01


This has worked for me thus far. 

uninstalled and reinstalled and this issue has resolved for me. 

Fixed

(Late status update.)