0
Not a bug

ctrl + alt + delete doesn't work from macOS

Wardrop 2 years ago updated 2 years ago 2

Is there any reason why pressing CTRL + ALT + DELETE from the macOS client doesn't work? If I remote a Windows computer, I'd expect pressing CTRL + ALT + DELETE to work. Instead, I need to use the "Miscellaneous -> Send Ctrl-Alt-Del" command. This seems unnecessary.

ConnectWise Control Version:
19.1
Server Affected:
Host Client Affected:
Guest Client Affected:

Answer

Answer
Not a bug

Good morning,


As it stands, you will need to submit the CAD via the macOS client misc menu. The following KB article describes keyboard shortcuts in general:


https://docs.connectwise.com/ConnectWise_Control_Documentation/Get_started/Knowledge_base/Keyboard_mapping_and_keyboard_shortcuts_reference


Also, I suggest taking a look through some of the existing feature requests related to CAD and adding a +1 to or commenting on requests as you see fit (feel free to add a new FR if you can't find one that matches your request):


http://control.product.connectwise.com/forums/1-new-features/


Regards,

Ben

Answer
Not a bug

Good morning,


As it stands, you will need to submit the CAD via the macOS client misc menu. The following KB article describes keyboard shortcuts in general:


https://docs.connectwise.com/ConnectWise_Control_Documentation/Get_started/Knowledge_base/Keyboard_mapping_and_keyboard_shortcuts_reference


Also, I suggest taking a look through some of the existing feature requests related to CAD and adding a +1 to or commenting on requests as you see fit (feel free to add a new FR if you can't find one that matches your request):


http://control.product.connectwise.com/forums/1-new-features/


Regards,

Ben

-1

Hey Ben,


This definitely seems more like a bug. CTRL, ALT and the Delete key all work independently from my Mac when connected to a windows client, so why shouldn't the CTRL + ALT + Delete combination work. CTRL + Alt + Delete has no special meaning on macOS, thus I would expect ScreenConnect to just pass these keys straight through to the client. Instead, it's like the combination is being explicitly blocked by the client, which I see no logical reason for it to do, hence why I believe this is a bug or oversight at least.


Cheers,

Tom