0
Pending Review

Force Users to Update ScreenConnect Client

Sean Keown 1 month ago 0

Right now, it's optional for our techs to update their screenconnect client each time a new version comes out or anytime i update wording and or hide a button in the client. 

It would be nice if i could chose to force these users to not be able to connect or start a control session if one of the two policies are not met. 

  • a.) Screenconnect Client out of date. 
    • Make this optional per instance or maybe let the admins set a minimum version that can connect. 
  • b.) When a policy change has been made to the platform. i.e Appearance changes or Buttons Hidden 
    • Example, policy version in the platform was changed to v10 and the agent is running policy version v5 then prevent it from connecting until they match. 
    • Make this optional depending on the admin's requirements or maybe prompt the admin to force require client update when the changes are made. 


This in turn will help ensure users are using the latest policies set in place. 

I can't tell you the number of users that i find are still running a screenconnect client from 2 years ago. 

Available in Version: