0
Under Review

Fetching IP Address in Reports

Josiah Fuller 8 months ago updated by Caitlin M Barnes (Product Manager) 8 months ago 3

Request:

Generate reports that include the IP Address of the host/user that is connect to the session.

Usage:

To track accounts that are being shared and to see what IP addresses have been accessing which sessions/devices.

This is massive for cybersecurity as I just had an account get locked due to too many failed attempts from different IP addresses - internally and a different country. Being able to tell what sessions/devices the bad actor connected to will help file anything with authorities and to help mitigate unauthorized access concerns.

Available in Version:
Closed

Hi Josiah,

Have you tried adding 'Network Address' to the report? If you haven't please do. There are couple more options such as 'SessionGuestPrivateNetworkAddress' and 'SessionGuestHardwareNetworkAddress' which too might be a help for you.

If this doesn't solve your problem, please contact our Support team for further help.

Click here to find out more on Reports and Report Manager.

I did try those 3 options and they did not supply what I needed. I did already contact Support letting them know I need the Public IP Addresses of the host that connected to the session. So, I guess then it would be called 'SessionHostPublicNetworkAddress' to keep with the current naming convention. When I asked Support, they weren't aware that this is an option and checked on it internally. They came back and told me this isn't currently possible and advised for me to come here to make a feature request.

I really don't understand why this was marked as closed before I answered your question if I had already done those things. 

Under Review

Hi Josiah, 

When I run a report of All Session Connections with 'NetworkAddress' I see the host's public IP address in my CSV. You can ctrl-f in the Report Manager modal to find plain ole 'Network Address' as opposed to SessionGuest... 

Maybe I'm missing something in your request, but let me know!