+2
Pending Review

Add suspend my input to Default Session Settings

AJ Lucas 1 year ago updated by TC100 7 months ago 9

Would be super helpful to be able to have suspend my input switched on by default so if you join an existing session you don't accidentally start clicking and moving things around on someone's screen. You should then still have the ability to switch this off once you do need to actually control something on the screen just like you can with other 5 options in Default Session settings screen.

Available in Version:

For those stumbling across this issue

Edit App.Config inside App_ClientConfig

Add this to the ScreenConnect.UserInterfaceSettings section

setting name="SuspendControlAtStartup" serializeAs="String"

True

I'm unsure if you need to reinstall the client app or the host app for this to work

What do you mean by App_ClientConfig? Where do I find this?

This did not work for me. I was personally looking for something that turns on "Suspend my Input" by default.

You need to reinstall the client on the machine you use to join the session (your machine) not their machine

Thanks! The issue was that the app.config in the App_ClientConfig folder didn't work for me. I dropped the same file in the root and it worked. Thanks for the assistance!

It is still unclear to me where this is:

"Edit App.Config inside App_ClientConfig

Add this to the ScreenConnect.UserInterfaceSettings section"

This will give you more details on creating the app.conifg file and the available settings. The reason the setting did not work for me is that the file (app.config) needed to be in the root of the screenconnect application folder. Not in the App_ClientConfig folder that documentation leads you to create.

https://docs.connectwise.com/ConnectWise_Control_Documentation/On-premises/Advanced_setup/Create_the_app.config_file

Hi Michael,

Ok so I followed all these instructions and saved the app.config in folder which for me is"C:\Program Files (x86)\ScreenConnect Client (1b9adafdd64401ae)".


I tried clearing the cache as it suggests in the troubleshooting but it still didn't work for me.

Looks like there is another way - try this.

Admin > Advanced > Other settings (Application Configuration).  Find and tick the options for Suspend Host Control


The wording says

"Prevent the host from controlling the guest's keyboard and mouse upon initial connection."

If you don't see the Advanced menu you need to install a extension called 'Advanced Configuration Editor' by 'ConnectWise Labs'