0
Pending Review

NVIDIA NVS 310 drivers on Windows 10 x64 give blank screen when remotely connected

michael 5 months ago updated by Sam Segura 5 months ago 2

All NVIDIA NVS 310 drivers on Windows 10 x64 give blank screen when remotely connected.  Have to switch to Microsoft Basic Display Adapter to get remote connection working again.  Even tried installing the oldest driver from NVIDIA's website I could find (release in 2017) but problem still happens.

Sucks cause if the display drivers get automatically updated, i.e. by Windows updates, it reverts back to the NVIDIA drivers which then requires me to boot into Safe Mode and switch it back if I need to do any work on the computer.  Would be nice if ConnectWise can roll out an actual fix for this instead of relying on using generic drivers but at least we have a workaround for the time being.

Available in Version:

*Update*

I was forced to reinstall the NVIDIA drivers since the generic Microsoft Basic Display Adapter drivers would not recognize the second monitor. The problem with my remote connection giving a blank screen appears to only happen when the monitors are powered off.  If monitors are powered on the NVIDIA NVS 310 drivers seems work fine when remotely connected.

Confirmed. 

On remote machine, client version: 19.2.24707.7131

Motherboard: GA-970A-DS3P FX

Monitor: Samsung T213

Video Card: Nvidia NVS 310

Nvidia driver 392.56 (downloaded 8/16/2019)

Resolution, 1600x900

Get blank screen as soon as monitors are unplugged from video card, resolution goes to some 4:3  resolution

Monitor using DisplayPort to DVI-D cable/adapter.

Observed, upon rebooting, briefly get the "restarting" page

On the host page, the preview of the screen does update. 

Connected monitor cable to video card, image comes back to normal.  

Turning off monitor, not affected.  

Pulling power cable from monitor - not affected

Removing the DVI cable from the DP adapter (leaving DP adapter connected to video card) - affected, screen goes blank but does not change shape.